HPlogo HP-UX Reference > X

xopen_networking(7)

HP-UX 11i Version 2: December 2007 Update
» 

Technical documentation

 » Table of Contents

 » Index

NAME

xopen_networking — X/Open Networking Interfaces

DESCRIPTION

X/Open has defined XTI, Sockets, and IP Address Resolution interfaces in X/Open CAE Specification, Networking Services, Issue 4 (UNIX 95) and X/Open CAE Specification, Networking Services, Issue 5 (UNIX 98). For a detailed description of these interfaces, please refer to the above specifications or to the book Go Solo, which is published by Prentice Hall. Go Solo also includes a CD ROM which contains the above specification to other SPEC 1170 man pages.

COMPILING ENVIRONMENT

Using any of the Networking Services(XTI, sockets) requires _XOPEN_SOURCE to be defined and _XOPEN_SOURCE_EXTENDED to be defined with the value 1.

The _XOPEN_SOURCE macro may be defined automatically by the compilation environment, but to ensure portability the application should define the macro either on the compilation command line, or at the beginning of each source module prior to the inclusion of any headers. The _XOPEN_SOURCE_EXTENDED macro will not be automatically defined by the compilation environment.

The c89 and cc utilities recognize the additional -l operand for standard libraries:

-l xnet

This operand makes visible all functions referenced in the above specification by having the linker search the appropriate X/Open networking interface libraries. If you also specify the -l c operand to explicitly specify the C library, you must specify the -l xnet operand before you specify the -l c operand.

AUTHOR

X/Open XTI, Sockets, and IP Address Resolution interfaces were developed by X/Open Company Limited.

SEE ALSO

Sockets Interfaces

read(1), write(1), accept(2), bind(2), close(2), connect(2), fcntl(2), getpeername(2), getsockname(2), getsockopt(2), listen(2), lseek(2), poll(2), recv(2), recvfrom(2), recvmsg(2), select(2), send(2), sendmsg(2), sendto(2), setsockopt(2), shutdown(2), socket(2), socketpair(2), fgetpos(3S), fsetpos(3S), ftell(3S).

IP Address Resolution Interfaces

gethostname(2), endhostent(3N), endnetent(3N), endprotoent(3N), endservent(3N), gethostbyaddr(3N), getnetbyaddr(3N), getprotobynumber(3N), getservbyport(3N), htonl(3N), inet_addr(3N), ntohl(3N), sethostent(3N), setnetent(3N), setprotoent(3N), setservent(3N).