HPlogo HP-UX Reference > M

mkfs_vxfs(1M)

HP-UX 11i Version 2: December 2007 Update
» 

Technical documentation

 » Table of Contents

 » Index

NAME

mkfs_vxfs: mkfs — construct a VxFS file system

SYNOPSIS

mkfs [-F vxfs] [-V] -m special

mkfs [-F vxfs] [-V] [-o [N] [X] [bsize= bsize] [inosize= n] [largefiles|nolargefiles] [logsize= n] [ninode= n] [version= n] ] special size

DESCRIPTION

mkfs creates a VxFS file system by writing on the special device file, unless either the -o N or -m option is specified. special must be the first argument on the command line after the options are given. The file system is created based on the options and size specified on the command line. The numeric size specifies the number of sectors in the file system. By default, size is specified in units of DEV_BSIZE sectors (currently, 1024 bytes). If size is not specified, mkfs determines the size of the special device. size can also be specified with a suffix to indicate a unit of measure other than sectors.

mkfs builds a file system with a root directory and a lost+found directory (see fsck_vxfs(1M)). The file system can have disk layout Version 4 or 5. Version 4 layout adds support for Access Control Lists. You can choose the disk layout version with the version=n option (see below).

The number of inodes allocated to a system depends on the disk layout version. Inode allocation is done dynamically. There are a minimum number of inodes allocated to the file system by mkfs, and any other inode allocations are done on an as-needed basis during file system use.

Options

mkfs recognizes the following options:

-F vxfs

Specify the VxFS file system type.

-m

Display the command line which was used to create the file system. The file system must already exist.

-V

Echo the completed command line, but do not execute the command. The command line is generated by incorporating the user-specified options and other information derived from /etc/fstab. This option allows the user to verify the command line.

-o specific_options

Specify options specific to the VxFS file system type. specific_options is a comma separated list of suboptions and/or keyword/attribute pairs.

The arguments aufirst, aupad, ausize, and nau, are no longer supported.

The following specific_options are valid on a VxFS file system:

N

Do not write the file system to the special file. This option gives all the information needed to create a file system but does not create it.

X

Create a file system in a file. Used for debugging only.

bsize=bsize

bsize is the block size for files on the file system and represents the smallest amount of disk space allocated to a file. The value of bsize must be based on a power of 2 selected from the range 1024 bytes to 8192 bytes. The default is 1024 bytes for file systems smaller than two terabytes. For Version 5 disk layout file systems larger than two terabytes, the maximum file system size is dependent on the block size. See the "VxFS Version 5 Disk Layout File System Sizes" topic in this section for more information. If bsize is not specified, the block size defaults are set to the appropriate value, based on size, when a file system is created.

inosize=n

n is the on-disk inode structure size for files on the file system. The valid values are 256 and 512 bytes. The default is 256. There is usually no reason to increase the inode size, and not using the default value can adversely affect file system performance.

largefiles|nolargefiles

Controls the largefiles flag for the file system. If largefiles is specified, the bit is set and files two gigabytes or larger can be created. If nolargefiles is specified, the bit is cleared and files created on the file system are limited to less than two gigabytes. The default is nolargefiles. See fsadm_vxfs(1M) and mkfs(1M).

If largefiles is not specified, and inosize is 256 the maximum number of inodes on the file system is approximately 8,380,000. If largefiles is not specified, and inosize is 512, the maximum number of inodes on the file system is approximately 4,190,000.

Note: Large files are supported on HP-UX 10.20 systems and above. Be careful when implementing large file system capability. System administration utilities such as backup may not operate correctly if they are not large-file aware.

logsize=n

n is the number of file system blocks to allocate for an activity logging area. The minimum value for the Version 4 and Version 5 disk layout is the number of blocks that make the log no less than 256K. The maximum value for n is the number of blocks that make the log no greater than 16384K. The default logsize is 16 megabytes for file systems that are are 512 megabytes or larger. For a small file system the default may be smaller to avoid wasting space.

A large log provides better performance on metadata-intensive workloads. A small log uses less space on the disk and leaves more room for file data. for example, and NFS-intensive workload performs better with a large log; a small floppy device requires a small log.

Note: The amount of virtual memory required by fsck (see fsck_vxfs(1M)) to check a VxFS file system is proportional to the size of the log. The maximum amount of virtual memory used is twice the size of the log. Therefore, the sum of physical memory and swap space must be at least 32 MB to ensure that a file system with a 16384K log can be cleaned. On small systems, take care not to create a file system with a log larger than half the available swap space. A maximum log size of one third the total of memory and swap space is a good rule of thumb (see swapinfo(1M)).

ninode=n

n is the maximum number of inodes in the file system. The actual maximum number of inodes is n rounded up to an appropriate boundary. The digit 0 and the string unlimited both mean that the number of inodes is unlimited. The default is unlimited.

version=n

n is the VxFS disk layout version number. Valid values are 4 and 5. The default is disk layout Version 5. The Version 5 disk layout supports file systems up to 32 terabytes in size.

Operands

mkfs recognizes the following operands:

special

Name of the special device file for the VxFS file system.

size

The number of sectors in the VxFS file system. See the "VxFS Version 5 Disk Layout File System Sizes" topic in this section for more information.

You can specify size with a suffix to indicate a unit of measure other than sectors. Append k or K to indicate the value is in kilobytes, m or M to indicate megabytes, or g or G to indicate gigabytes. An appended letter can be separated from the number by a space. In that case, enclose the letter and number in a set of quotes, for example:

"512 k"

VxFS Version 5 Disk Layout File System Sizes

The Version 5 disk layout supports file systems up to 32 terabytes. The maximum size of the file system you can create depends on the block size. (The actual maximum file system size is slightly less than the maximum values in bytes, described below.)

The following table defines the file system sizes and their associated values:

------------------------------------------ | Maximum File System Size ------------------------------------------------------ Block Size | In sectors | In bytes ------------------------------------------------------ 1024 bytes | 4,294,967,039 | approximately 4 TB 2048 bytes | 8,589,934,078 | approximately 8 TB 4096 bytes | 17,179,868,156 | approximately 16 TB 8192 bytes | 34,359,736,312 | approximately 32 TB ------------------------------------------------------

Note: Sector size (in bytes) is specified by the DEV_BSIZE system parameter.

RETURN VALUE

mkfs returns the following value:

0

Successful completion.

1

Command failed due to syntax error.

32

Other error occurred.

EXAMPLES

Use mkfs to create a VxFS file system on /dev/rdsk/c0t6d0:

mkfs -F vxfs /dev/rdsk/c0t6d0 1024

Use mkfs to determine the command that was used to create the VxFS file system on /dev/rdsk/c0t6d0:

mkfs -F vxfs -m /dev/rdsk/c0t6d0

Create a VxFS file system on /dev/vgqa/lvol1, with a Version 4 disk layout and largefiles capability:

mkfs -F vxfs -o version=4,largefiles /dev/vgqa/lvol1

WARNINGS

If you want to reuse a special device that was previously used by LVM, you must first wipe out all the LVM information remaining on the disk. Use pvremove(1M) to remove the LVM information before executing mkfs_vxfs(1M). (You can also remove the LVM information by initializing the device with mediainit(1), but that is slower.)

The -o largefiles option should be used with care, since older applications do not react correctly when confronted with large files.

SEE ALSO

df_vxfs(1M), fsadm_vxfs(1M), fsck_vxfs(1M), mkfs(1M), mount_vxfs(1M), newfs_vxfs(1M), swapinfo(1M), dir(4), fs_vxfs(4).

Veritas Volume Manager Administrator's Guide

STANDARDS CONFORMANCE

mkfs : SVID3