HPlogo HP-UX Reference > H

hpux(1M)

PA-RISC Systems Only
HP-UX 11i Version 2: December 2007 Update
» 

Technical documentation

 » Table of Contents

 » Index

NAME

hpux — HP-UX bootstrap

SYNOPSIS

hpux [-F] [-lm] [-vm] [-tm] [-lq] [-a[C|R |S|D] devicefile] [-f number]

  • [-i string] [boot] [devicefile]

hpux ll [devicefile] (same as hpux ls -aFln)

hpux ls [-aFiln] [devicefile]

hpux set autofile devicefile string

hpux show autofile [devicefile]

hpux -v

hpux restore devicefile (Workstations only; see DEPENDENCIES.)

DESCRIPTION

hpux is the HP-UX specific secondary system loader (SSL) utility for bootstrap (see isl(1M) for the initial system loader). It supports the operations summarized below, as shown in the SYNOPSIS and detailed later in this DESCRIPTION.

This hpux(1M) manpage only documents features on PA-RISC sysetems. For bootstrap information on Itanium(R)-based systems, see hpux.efi(1M).

Operations

The following operations are supported on PA-RISC systems:

boot

Loads an object file from an HP-UX file system or raw device and transfers control to the loaded image. (Note, the boot operation is position dependent).

ll

Lists the contents of HP-UX directories in a format similar to ls -aFln. (See ls(1); ls only works on a local disk with a HFS file system).

ls

Lists the contents of HP-UX directories. (See ls(1); ls only works on a local disk with a HFS file system).

show autofile

Displays the contents of the autoexecute file.

set autofile

Changes the contents of the autoexecute file to that specified by string.

-v

Displays the release and version numbers of the hpux utility.

restore

Recovers the system from a properly formatted bootable tape. (Workstation specific; see DEPENDENCIES.)

hpux commands can be given interactively from the keyboard, or provided in an isl autoexecute file.

hpux is limited to operations on the interface initialized by pdc(1M). In most cases, operations are limited to the boot device interface.

Notation

hpux accepts numbers (numeric constants) in many of its options. Numbers follow the C language notation for decimal, octal, and hexadecimal constants. A leading 0 (zero) implies octal and a leading 0x or 0X implies hexadecimal. For example, 037, 0x1F, 0X1f, and 31 all represent the same number, decimal 31.

hpux boot, ll, ls, set autofile, show autofile, and restore operations accept devicefile specifications, which have the following format:

manager(w/x.y.z;n)filename

The devicefiles specification is comprised of a device name and a file name. The device name (manager(w/x. y.z;n) ), consists of a generic name of an I/O system manager (device or interface driver) such as disc, a hardware path to the device, and minor number. The manager name can be omitted entirely if the default is used. w/x.y. z is the physical hardware path to the device, identifying bus converters, slot numbers, and hardware addresses. For workstations, there are a set of mnemonics that can be used instead of the hardware paths. The n is the minor number that controls manager-dependent functionality. The file name part, filename, is a standard HP-UX path name. Some hpux operations have defaults for particular components. A devicefile specification containing a device part only specifies a raw device. A devicefile specification containing a file name implies that the device contains an HP-UX file system, and that the filename resides in that file system.

A typical boot devicefile specification is

disc(2/4.0.0;0)/stand/vmunix

The manager is disc, the hardware path to the disk device is 2/4.0.0, the minor number shown as 0 by default, and the /stand/vmunix is the filename for the boot device.

hpux now supports a consolidated list of managers: disc, tape, and lan. The manager disc manages all disks connected via SCSI, (formerly disc3), and all autochanger disk devices (formerly disc30). The manager lan manages remote boot through the HP28652A NIO based LAN interface (formerly lan1). Remote boot is currently supported on this card only and not on any CIO-based LAN card. The manager tape manages tape drives via SCSI (formerly tape2).

The hardware path in a devicefile specification is a string of numbers, each suffixed by slash, (/), followed by a string of numbers separated by dots (.), each number identifying a hardware component notated sequentially from the bus address to the device address. A hardware component suffixed by a slash indicates a bus converter and may not be necessary on your machine. For example, in w/x.y. z w is the address of the bus converter, x is the address of the MID-BUS module, y is the CIO slot number, and z is the HP27111 bus address.

The minor number, n, in a devicefile specification controls driver-dependent functionality. (See the manual, Configuring HP-UX for Peripherals, for minor-number bit assignments of specific drivers).

File names are standard HP-UX path names. No preceding slash (/) is necessary and specifying one will not cause problems.

Defaults

Default values chosen by hpux to complete a command are obtained through a sequence of steps. First, any components of the command specified explicitly are used. If the command is not complete, hpux attempts to construct defaults from information maintained by pdc (see pdc(1M)). If sufficient information to complete the command is unavailable, the autoexecute file is searched. If the search fails, any remaining unresolved components of the command are satisfied by hard-coded defaults.

There is no hard-coded default choice for a manager; if none can be chosen, hpux reports an error.

When the hardware path to the boot device is not specified, hpux defaults to information maintained by pdc. The hardware path element has no hard-coded default.

If the minor number element is not supplied, hpux takes its default from the autoexecute file. Failing that, the hard-coded default of 0 is used.

For the boot command, a devicefile specification without a file name indicates that the boot device does not contain an HP-UX file system. hpux interprets this as a NULL (instead of missing) file name and does not search for a default. If the entire devicefile specification is missing, hpux searches for a default; either the autoexecute file contents or the hard-coded default is chosen.

There are two possible hard-coded default devicefile specifications. One hard-coded default devicefile specification is /vmunix. The other hard-coded default devicefile specification is /stand/vmunix.

If you have a LVM or VxVM system where the boot volume and the root volume are on different logical volumes, the kernel would be /vmunix. This is because the boot volume will be mounted under /stand when the system is up.

For all other configurations, the kernel would be /stand/vmunix.

The search order for the hard-coded defaults is /stand/vmunix and then /vmunix.

boot Operation

The boot operation loads an object file from an HP-UX file system or raw device as specified by the optional devicefile. It then transfers control to the loaded image.

Any missing components in a specified devicefile are supplied with a default. For example, a devicefile of vmunix would actually yield:

disc(8.0.0;0)vmunix

and a devicefile of (8/0/19/0.14.0)/stand/vmunix, for booting from the disk at Ultra Wide SCSI address 14, would yield

disc(8/0/19/0.14.0;0)/stand/vmunix

To boot a saved kernel configuration, specify a devicefile of /stand/configname/vmunix, where configname is the name of the saved configuration to boot. For more details on saved kernel configurations, see kconfig(5).

Regardless of how incomplete the specified devicefile may be, boot announces the complete devicefile specification used to find the object file. Along with this information, boot gives the sizes of the TEXT, DATA, and BSS, segments and the entry offset of the loaded image, before transferring control to it.

The boot operation accepts several options. Note that boot options must be specified positionally as shown in the syntax statement in the SYNOPSIS. Options for the boot operations are as follows:

-a[C|R|S|D] devicefile

Accept a new location (as specified by devicefile) and pass it to the loaded image. If that image is an HP-UX kernel, the kernel will erase its predefined I/O configuration, and configure in the specified devicefile. If the C, R, S, or D option is specified, the kernel configures the devicefile as the console, root, swap, or dump device, respectively. Note that -a can be repeated multiple times.

-fnumber

Use the number and pass it as the flags word to the loaded image.

-istring

Set the initial run-level for init (see init(1M)) when booting the system. The run-level specified will override any run-level specified in an initdefault entry in /etc/inittab (see inittab(4)).

-lm

Boot the system in LVM maintenance mode, configure only the root volume, and then initiate single user mode.

-vm

Boot the system in VxVM maintenance mode, configure only the root volume, and then initiate single user mode.

-tm

Boot the system in tunable maintenance mode, also known as "failsafe boot" mode. This option will disregard the tunable settings and module settings in the kernel configuration, and boot with known good settings instead. Note: some systems that have been updated from earlier versions of HP-UX have boot loaders that do not support this flag. On those systems, the flag -f0x40000 can be used instead.

-lq

Boot the system with quorum override option. This option is used in a scenario where a disk is removed from the system or is otherwise unavailable, but the corresponding entry for the physical volume has not yet been removed from the volume group using vgreduce.

-F

Used with SwitchOver/UX software. However, SwitchOver/UX is not supported on HP-UX 10.30 or later systems. The -F option is used to ignore any locks on the boot disk. The -F option should be used only when it is known that the processor holding the lock is no longer running. (If this option is not specified and a disk is locked by another processor, the kernel will not boot from it, to avoid the corruption that would result if the other processor were still using the disk).

boot places some restrictions on object files it can load. It accepts only the HP-UX magic numbers EXECMAGIC (0407), SHAREMAGIC (0410), and DEMANDMAGIC (0413). See magic(4). The object file must contain an Auxiliary Header of the HPUX_AUX_ID type and it must be the first Auxiliary Header (see a.out(4)).

ll and ls Operations

The ll and ls operations list the contents of the HP-UX directory specified by the optional devicefile. The output is similar to that of ls -aFl command, except the date information is not printed.

The default devicefile is generated just as for boot, defaulting to the current directory.

set autofile Operation

The set autofile operation overwrites the contents of the autoexecute file, autofile, with the string specified (see autoexecute in the EXAMPLES section).

show autofile Operation

The show autofile operation displays the contents of the autoexecute file, autofile (see autoexecute in the EXAMPLES section).

DIAGNOSTICS

If an error is encountered, hpux prints diagnostic messages to indicate the cause of the error. These messages fall into the General, Boot, Copy, Configuration, and System Call categories. System Call error messages are described in errno(2). The remaining messages are listed below.

General

bad minor number in devicefile spec

The minor number in the devicefile specification is not recognized.

bad path in devicefile spec

The hardware path in the devicefile specification is not recognized.

command too complex for parsing

The command line contains too many arguments.

no path in devicefile spec

The devicefile specification requires (but does not contain) a hardware path component.

panic (in hpuxboot): (display==number, flags==number) string

A severe internal hpux error has occurred. Report to your nearest HP Field Representative.

Boot

bad magic

The specified object file does not have a recognizable magic number.

bad number in flags spec

The flags specification in the -f option is not recognized.

Exec failed: Cannot find /stand/vmunix or /vmunix.

Neither /stand/vmunix or /vmunix could be found.

booting from raw character device

In booting from a raw device, the manager specified only has a character interface, which might cause problems if the block size is incorrect.

isl not present, please hit system RESET button to continue

An unsuccessful boot operation has overlaid isl in memory. It is impossible to return control to isl.

short read

The specified object file is internally inconsistent; it is not long enough.

would overlay

Loading the specified object file would overlay hpux.

Configuration

cannot add path, error number

An unknown error has occurred in adding the hardware path to the I/O tree. The internal error number is given. Contact your HP Field Representative.

driver does not exist

The manager specified is not configured into hpux.

driver is not a logical device manager

The manager named is not that of a logical device manager and cannot be used for direct I/O operations.

error rewinding device

An error was encountered attempting to rewind a device.

error skipping file

An error was encountered attempting to forward-space a tape device.

negative skip count

The skip count, if specified, must be greater than or equal to zero.

no major number

The specified manager has no entry in the block or character device switch tables.

path incompatible with another path

Multiple incompatible hardware paths have been specified.

path long

The hardware path specified contains too many components for the specified manager.

path short

The hardware path specified contains too few components for the specified manager.

table full

Too many devices have been specified to hpux.

EXAMPLES

As a preface to the examples which follow, here is a brief overview of HP-UX system boot-up sequences.

Automatic Boot

Automatic boot processes on various HP-UX systems follow similar general sequences. When power is applied to the HP-UX system processor, or the system Reset button is pressed, processor-dependent code (firmware) is executed to verify hardware and general system integrity (see pdc(1M)). After checking the hardware, pdc gives the user the option to override the autoboot sequence by pressing the Esc key. At that point, a message resembling the following usually appears on the console.

(c) Copyright. Hewlett-Packard Company. 1994. All rights reserved. PDC ROM rev. 130.0 32 MB of memory configured and tested. Selecting a system to boot. To stop selection process, press and hold the ESCAPE key...

If no keyboard activity is detected, pdc commences the autoboot sequence by loading isl (see isl(1M)) and transferring control to it. Since an autoboot sequence is occurring, isl finds and executes the autoexecute file which, on an HP-UX system, requests that hpux be run with appropriate arguments. Messages similar to the following are displayed by isl on the console:

Booting from: scsi.6 HP 2213A Hard booted. ISL Revision A.00.09 March 27, 1990 ISL booting hpux boot disk(;0)/stand/vmunix

hpux, the secondary system loader, then announces the operation it is performing, in this case boot, the devicefile from which the load image comes, and the TEXT size, DATA size, BSS size, and start address of the load image, as shown below, before control is passed to the image.

Booting disk(scsi.6;0)/stand/vmunix 966616+397312+409688 start 0x6c50

The loaded image then displays numerous configuration and status messages.

Interactive Boot

To use hpux interactively, isl must be brought up in interactive mode by pressing the Esc key during the interval allowed by pdc. pdc then searches for and displays all bootable devices and presents a set of boot options. If the appropriate option is chosen, pdc loads isl and isl interactively prompts for commands. Information similar to the following is displayed:

Selection process stopped. Searching for Potential Boot Devices. To terminate search, press and hold the ESCAPE key. Device Selection Device Path Device Type ------------------------------------------------------------- P0 scsi.6.0 QUANTUM PD210S P1 scsi.1.0 HP 2213A p2 lan.ffffff-ffffff.f.f hpfoobar b) Boot from specified device s) Search for bootable devices a) Enter Boot Administration mode x) Exit and continue boot sequence Select from menu: b p0 isl Trying scsi.6.0 Boot path initialized. Attempting to load IPL. Hard booted. ISL Revision A.00.2G Mar 27, 1994 ISL>

Although all of the operations and options of hpux can be used from isl interactively, they can also be executed from an autoexecute file. In the examples below, user input is the remainder of the line after each ISL> prompt shown. The remainder of each example is text displayed by the system. Before going over specific examples of the various options and operations of hpux, here is an outline of the steps taken in the automatic boot process. Although the hardware configuration and boot paths shown are for a single server machine, the user interfaces are consistent across all models. When the system Reset button is depressed, pdc executes self-test, and assuming the hardware tests pass, pdc announces itself, sends a BELL character to the controlling terminal, and gives the user 10 seconds to override the autoboot sequence by entering any character. Text resembling the following is displayed on the console:

Processor Dependent Code (PDC) revision 1.2 Duplex Console IO Dependent Code (IODC) revision 3 Console path = 56.0.0.0.0.0.0 (dec) 38.0.0.0.0.0.0 (hex) Primary boot path = 44.3.0.0.0.0.0 (dec) 2c.00000003.0.0.0.0.0 (hex) Alternate boot path = 52.0.0.0.0.0.0 (dec) 34.0.0.0.0.0.0 (hex) 32 MB of memory configured and tested. Autosearch for boot path enabled To override, press any key within 10 seconds.

If no keyboard character is pressed within 10 seconds, pdc commences the autoboot sequence by loading isl and transferring control to it. Because an autoboot sequence is occurring, isl merely announces itself, finds and executes the autoexecute file which, on an HP-UX system, requests that hpux be run with appropriate arguments. The following is displayed on the console.

10 seconds expired. Proceeding with autoboot. Trying Primary Boot Path ------------------------ Booting... Boot IO Dependent Code (IODC) revision 2 HARD Booted. ISL Revision A.00.2G Mar 20, 1994 ISL booting hpux

hpux then announces the operation it is performing, in this case boot, the devicefile from which the load image comes, and the TEXT size, DATA size, BSS size, and start address of the load image. The following is displayed before control is passed to the image.

Boot : disc3(44.3.0;0)/stand/vmunix 3288076 + 323584 + 405312 start 0x11f3e8

Finally, the loaded image displays numerous configuration and status messages, then proceeds to init run-level 2 for multiuser mode of operation.

isl must be brought up in interactive mode to use the operations and options of hpux. To do this, simply enter a character during the 10 second interval allowed by pdc. pdc then asks if the primary boot path is acceptable. Answering yes (Y) is usually appropriate. pdc then loads isl and isl interactively prompts for commands. The following lines show the boot prompt, the Y response, subsequent boot messages, and finally the Initial System Loader (ISL) prompt that are sent to the display terminal:

Boot from primary boot path (Y or N)?> y Interact with IPL (Y or N)?> y Booting... Boot IO Dependent Code (IODC) revision 2 HARD Booted. ISL Revision A.00.2G Mar 20, 1994 ISL>

Although all of the operations and options of hpux can be used from isl interactively, they can also be executed from an autoexecute file. In the examples below, all user input follows the ISL> prompt on the same line. Subsequent text is resultant messages from the ISL.

Default Boot

Entering hpux initiates the default boot sequence. The boot path read from pdc is 8.0.0, the manager associated with the device at that path is disc, the minor number, in this case derived from the autoexecute file, is 4 specifying section 4 of the disk, and the object file name is /stand/vmunix.

ISL> hpux Boot : disc3(44.3.0;0)/stand/vmunix 3288076 + 323584 + 405312 start 0x11f3e8

Booting Another Kernel Configuration

In this example, hpux initiates a boot operation for the saved kernel configuration myconfig.

ISL> hpux myconfig/vmunix Boot : disc3(44.3.0;0)/stand/myconfig/vmunix 3288076 + 323584 + 405312 start 0x11f3e8

Booting From Another Section

In this example (shown for backward compatibility), a kernel is booted from another section of the root disk. For example, suppose kernel development takes place under /mnt/azure/root.port which happens to reside in its own section, section 3 of the root disk. By specifying a minor number of 3 in the above example, the object file sys.azure/S800/vmunix is loaded from /mnt/azure/root.port.

ISL> hpux (;3)sys.azure/S800/vmunix Boot : disc(8.0.0;0x3)sys.azure/S800/vmunix 966616+397312+409688 start 0x6c50

Booting From Another Disk

Only the hardware path and file name are specified in this example. All other values are boot defaults. The object file comes from the file system on another disk.

ISL> hpux (52.5.0.0)/stand/vmunix Boot : disc(52.5.0.0)/stand/vmunix 966616+397312+409688 start 0x6c50

Booting From LAN

This example shows how to boot a cluster client from the LAN. Though this example specifies a devicefile, you can also use default boot, as shown in a previous example. For a boot operation other than default boot, the file name must be specified and can be no longer than 11 characters. Booting to isl from a local disk then requesting an image to be loaded from the LAN is not supported.

ISL> hpux lan(32)/stand/vmunix Boot : lan(32;0x0)/stand/vmunix 966616+397312+409688 start 0x6c50

Booting To Single User Mode

In this example, the -i option is used to make the system come up in run-level s, for single user mode of operation.

ISL> hpux -is Boot : disc(8.0.0;0x0)/stand/vmunix 966616+397312+409688 start 0x6c50 (Kernel Startup Messages Omitted) INIT: Overriding default level with level 's' INIT: SINGLE USER MODE WARNING: YOU ARE SUPERUSER !! #

Booting With A Modified I/O Configuration

Here, a disc driver is configured in at CIO slot 5, SCSI address 5 as a dump device. Regardless of what was present in the kernel's original I/O configuration, the driver disc is now configured at that hardware path. Similarly, asio0 is configured in at CIO slot 63 which is to be the console. The only other devices configured are the console and root device, which boot derived from pdc.

ISL> hpux -aC asio0(8/0/63) -aD disc(8/16/5.5) Boot : disk(8/0/19/0.14.0.0.0.0.0;0)/stand/vmunix : Adding console (8.0.63;0)... : Adding dump (8.16.5.5;0)... 6463488 + 1101824 + 939616 start 0x39168 (Additional Kernel Startup Messages Omitted)

Displaying The Autoexecute File

In this example, show autofile is used to print the contents of the autoexecute file residing in the boot LIF, on the device from which hpux was booted. Optionally, a devicefile can be specified in order to read the autoexecute file from the boot LIF of another boot device.

ISL> hpux show autofile Show autofile : AUTO file contains (hpux)

Changing The Autoexecute File

This example shows how to change the contents of the autoexecute file. Once done, the system can be reset, and the new command will be used during any unattended boot.

ISL> hpux set autofile "hpux /stand/myconfig/vmunix" Set autofile : disk(2/0/1.3.0.0.0.0.0;0) : AUTO file now contains "(hpux /stand/myconfig/vmunix)"

Listing Directory Contents

The contents of the directory (/stand) on the root disk are listed. The format shows the file protections, number of links, user id, group id, and size in bytes for each file in the directory. There are three available kernel configurations to boot: the default configuration (vmunix), the automatic backup configuration (backup), and one other saved configuration (good). Listing the files over the LAN is not supported.

ISL> hpux ll /stand Ls : disk(2/0/1.3.0.0.0.0.0;0)/stand dr-xr-xr-x 9 2 2 1024 ./ dr-xr-xr-x 14 2 2 1024 ../ drwxr-xr-x 5 0 3 1024 backup/ -rw-r--r-- 1 0 3 19 bootconf drwxr-xr-x 3 0 3 1024 bootfs/ drwxr-xr-x 5 0 3 1024 current/ drwxr-xr-x 5 0 3 1024 good/ -rw-r--r-- 1 0 3 4376 ioconfig -r--r--r-- 1 0 3 82 kernrel drwxr-xr-x 2 0 3 1024 krs/ drwxr-xr-x 2 0 0 65536 lost+found/ drwxr-xr-x 5 0 3 1024 nextboot/ -rw------- 1 0 0 12 rootconf -rw-r--r-- 1 0 3 1892 system -rwxr-xr-x 4 0 3 17163704 vmunix*

Getting The Version

The -v option is used to get the version numbers of hpux.

ISL> hpux -v Release: 10.00 Release Version: @(#) X10.20.B HP-UX() #1: Dec 4 1995 16:55:08

DEPENDENCIES

Workstations Only

The restore operation is provided as a recovery mechanism in the event that a disk becomes totally corrupted. It copies data from a properly formatted bootable tape to disk. When this tape contains a backup image of the disk, the entire disk is restored. To create a properly formatted tape (DDS ONLY), the following commands should be executed:

dd if=/usr/lib/uxbootlf of=/dev/rmt/0mn bs=2k dd if=/dev/rdsk/1ss of=/dev/rmt/0m bs=64k

The first dd puts a boot area on the tape, making it a bootable image (see dd(1)). Once the boot image is on tape, the tape is not rewound. The next dd appends an image of the disk to the tape. The entire process takes about one hour for a 660 MB HP2213 disk. To avoid later problems with fsck after the disk is restored, bring the system to single user mode and type sync a few times before doing the second dd (see fsck(1M)). Once created, the tape can be used to completely restore the disk:

1.

Insert the tape into the tape drive.

2.

Instruct the machine to boot to ISL from the tape. This is usually done by specifying scsi.3 as the boot path.

3.

Enter the following in response to the ISL prompt:

ISL> hpux restore disk(scsi.1;0)

This restores the disk image from the tape to the actual disk at scsi.1. Any existing data on the disk will be lost. This command destroys the contents of the device specified by devicefile. The restoration process takes about one hour for a 660 MB drive.

NOTE: There is a 2 GB limit on the amount of data that can be restored. The tape and disk must be on the boot device interface.

Also, this command may be replaced in the future by superior installation and recovery mechanisms. At that time, this command will be removed.