HPlogo HP-UX Reference Volume 5 of 5 > t

types(5)

» 

Technical documentation

Complete book in PDF

 » Table of Contents

 » Index

NAME

types — primitive system data types

SYNOPSIS

#include <sys/types.h>

DESCRIPTION

REMARKS

The example given on this page is a typical version. The type names are in general expected to be present, although exceptions (if any) may be described in DEPENDENCIES. In most cases the fundamental type which implements each typedef is implementation dependent as long as source code which uses those typedefs need not be changed. In some cases the typedef is actually a shorthand for a commonly used type, and will not vary.

The data types defined in the include file are used in HP-UX system code; some data of these types are accessible to user code:

typedef struct { int r[1]; } *physadr; typedef long daddr_t; typedef char *caddr_t; typedef unsigned int uint; typedef unsigned short ushort; typedef ushort ino_t; typedef short cnt_t; typedef long time_t; typedef long dev_t; typedef long off_t; typedef long paddr_t; typedef long key_t; typedef short pid_t; typedef long uid_t; typedef long gid_t;

Note that the defined names above are standardized, but the actual type to which they are defined may vary between HP-UX implementations.

The meanings of the types are:

physadr

used as a pointer to memory; the pointer is aligned to follow hardware-dependent instruction addressing conventions.

daddr_t

used for disk addresses except in an inode on disk, see fs(4).

caddr_t

used as an untyped pointer or a pointer to untyped memory.

uint

shorthand for unsigned integer.

ushort

shorthand for unsigned short.

ino_t

used to specify I-numbers.

cnt_t

used in some implementations to hold reference counts for some kernel data structures.

time_t

time encoded in seconds since 00:00:00 GMT, January 1, 1970.

dev_t

specifies kind and unit number of a device, encoded in two parts known as major and minor.

off_t

offsets measured in bytes from the beginning of a file.

paddr_t

used as an integer type which is properly sized to hold a pointer.

key_t

the type of a key used to obtain a message queue, semaphore, or shared memory identifier, see stdipc(3C).

pid_t

used to specify process and process group identifiers.

uid_t

used to specify user identifiers.

gid_t

user to specify group identifiers.

SEE ALSO

fs(4).

STANDARDS CONFORMANCE

<sys/types.h>: AES, SVID3, XPG2, XPG3, XPG4, FIPS 151-2, POSIX.1

© Hewlett-Packard Development Company, L.P.