HPlogo HP-UX Reference Volume 3 of 5 > f

fs(4)

» 

Technical documentation

Complete book in PDF

 » Table of Contents

 » Index

NAME

fs — format of file system volume

SYNOPSIS

#include <sys/types.h> #include <sys/param.h> #include <sys/fs.h> #include <sys/inode.h> #include <sys/ino.h> #include <sys/sysmacros.h>

DESCRIPTION

Every file system storage volume has a common format for certain vital information. The first 8 kbytes on a volume contain a volume header which identifies that volume as a Logical Interchange Format (LIF) volume. Such volume may be divided into a number of sections.

Each section can contain a file system. The first 8 kbytes in each section is ignored, except where it coincides with the volume header discussed above. The actual file system begins next with the "super block." The layout of the super block as defined by the include file <sys/fs.h> is:

#define FS_MAGIC 0x011954 #define FS_MAGIC_LFN 0x095014 #define FS_CLEAN 0x17 #define FS_OK 0x53 #define FS_NOTOK 0x31 struct fs { struct fs *fs_link; /* linked list of file systems */ struct fs *fs_rlink; /* used for incore super blocks */ daddr_t fs_sblkno; /* addr of super-block in filesys */ daddr_t fs_cblkno; /* offset of cyl-block in filesys */ daddr_t fs_iblkno; /* offset of inode-blocks in filesys*/ daddr_t fs_dblkno; /* offset of first data after cg */ long fs_cgoffset; /* cylinder group offset in cylinder*/ long fs_cgmask; /* used to calc mod fs_ntrak */ time_t fs_time; /* last time written */ long fs_size; /* number of blocks in fs */ long fs_dsize; /* number of data blocks in fs */ long fs_ncg; /* number of cylinder groups */ long fs_bsize; /* size of basic blocks in fs */ long fs_fsize; /* size of frag blocks in fs */ long fs_frag; /* number of frags in a block in fs*/ /* these are configuration parameters */ long fs_minfree; /* minimum percentage of free blocks*/ long fs_rotdelay; /* num of ms for optimal next block */ long fs_rps; /* disk revolutions per second */ /* these fields can be computed from the others */ long fs_bmask; /* ``blkoff'' calc of blk offsets */ long fs_fmask; /* ``fragoff'' calc of frag offsets */ long fs_bshift; /* ``lblkno'' calc of logical blkno */ long fs_fshift; /* ``numfrags'' calc number of frags*/ /* these are configuration parameters */ long fs_maxcontig; /* max number of contiguous blks */ long fs_maxbpg; /* max number of blks per cyl group */ /* these fields can be computed from the others */ long fs_fragshift; /* block to frag shift */ long fs_fsbtodb; /* fsbtodb and dbtofsb shift constant*/ long fs_sbsize; /* actual size of super block */ long fs_csmask; /* csum block offset */ long fs_csshift; /* csum block number */ long fs_nindir; /* value of NINDIR */ long fs_inopb; /* value of INOPB */ long fs_nspf; /* value of NSPF */ long fs_sparecon[6]; /* reserved for future constants */ /* sizes determined by number of cylinder groups and their sizes */ daddr_t fs_csaddr; /* blk addr of cyl grp summary area */ long fs_cssize; /* size of cyl grp summary area */ long fs_cgsize; /* cylinder group size */ /* these fields should be derived from the hardware */ long fs_ntrak; /* tracks per cylinder */ long fs_nsect; /* sectors per track */ long fs_spc; /* sectors per cylinder */ /* this comes from the disk driver partitioning */ long fs_ncyl; /* cylinders in file system */ /* these fields can be computed from the others */ long fs_cpg; /* cylinders per group */ long fs_ipg; /* inodes per group */ long fs_fpg; /* blocks per group * fs_frag */ /* this data must be re-computed after crashes */ struct csum fs_cstotal; /* cylinder summary information */ /* these fields are cleared at mount time */ char fs_fmod; /* super block modified flag */ char fs_clean; /* file system is clean flag */ char fs_ronly; /* mounted read-only flag */ char fs_flags; /* currently unused flag */ char fs_fsmnt[MAXMNTLEN];/* name mounted on */ /* these fields retain the current block allocation info */ long fs_cgrotor; /* last cg searched */ struct csum *fs_csp[MAXCSBUFS]; /* list of fs_cs info buffers */ long fs_cpc; /* cyl per cycle in postbl */ short fs_postbl[MAXCPG][NRPOS];/*head of blocks per rotation */ long fs_magic; /* magic number */ char fs_fname[6]; /* name of file system */ char fs_fpack[6]; /* pack name of file system */ u_char fs_rotbl[1]; /* list of blocks for each rotation */ /* actually longer */ };

A file system consists of a number of cylinder groups. Each cylinder group has inodes and data.

A file system is described by its super-block, which in turn describes the cylinder groups. The super-block is critical data and is replicated in each cylinder group to protect against catastrophic loss. This is done at file system creation time and the critical super-block data does not change, so the copies need not be referenced further unless disaster strikes.

Addresses stored in inodes are capable of addressing fragments of `blocks'. File system blocks of at most size MAXBSIZE can be optionally broken into smaller pieces, each of which is addressable; these pieces may be DEV_BSIZE, or some multiple of a DEV_BSIZE unit (DEV_BSIZE is defined in <sys/param.h>).

Large files consist of exclusively large data blocks. To avoid undue wasted disk space, the last data block of a file is allocated only as many fragments of a large block as are necessary, if that file is small enough to not require indirect data blocks. The file system format retains only a single pointer to such a fragment, which is a piece of a single large block that has been divided. The size of such a fragment is determinable from information in the inode, using the blksize(fs, ip, lbn) macro.

The file system records space availability at the fragment level; to determine block availability, aligned fragments are examined.

I-numbers begin at 0. Inodes 0 and 1 are reserved. Inode 2 is used for the root directory of the file system. The lost+found directory is given the next available inode when it is initially created by mkfs.

fs_minfree gives the minimum acceptable percentage of file system blocks that can be free. If the freelist drops below this level, only the super-user may continue to allocate blocks. This can be set to 0 if no reserve of free blocks is deemed necessary. However, severe performance degradations result if the file system is run at greater than 90% full; thus the default value of fs_minfree is 10%.

The best trade-off between block fragmentation and overall disk utilization and performance varies for each intended use of the file system. Suggested values can be found in the system administrator's manual for each implementation.

Cylinder-Group-Related Limits

Each cylinder keeps track of the availability of blocks at different rotational positions, so that sequential blocks can be laid out with minimum rotational latency. NRPOS is the number of rotational positions which are distinguished. For example, with NRPOS 8 the resolution of the summary information is 2ms for a typical 3600 rpm drive.

fs_rotdelay gives the minimum number of milliseconds to initiate another disk transfer on the same cylinder. It is used in determining the rotationally optimal layout for disk blocks within a file; the default value for fs_rotdelay is 2ms. Suggested values of fs_rotdelay for different disks can be found in the system administrator's manual.

Each file system has a statically allocated number of inodes. An inode is allocated for each NBPI bytes of disk space. The inode allocation strategy is extremely conservative.

MAXIPG bounds the number of inodes per cylinder group, and is needed only to keep the structure simpler by having only a single variable size element (the free bit map).

Important Note: MAXIPG must be a multiple of INOPB(fs).

MINBSIZE is the smallest allowable block size. With a MINBSIZE of 4096, it is possible to create files of size 232 with only two levels of indirection. MINBSIZE must be big enough to hold a cylinder group block, thus MINBSIZE must always be greater than sizeof(struct cg). Note that super blocks are never more than size SBSIZE.

The path name on which the file system is mounted is maintained in fs_fsmnt. MAXMNTLEN defines the amount of space allocated in the super block for this name. The limit on the amount of summary information per file system is defined by MAXCSBUFS. It is currently parameterized for a maximum of two million cylinders.

Per cylinder group information is summarized in blocks allocated from the first cylinder group's data blocks. These blocks are read in from fs_csaddr (size fs_cssize) in addition to the super block.

Important Note: sizeof (struct csum) must be a power of two in order for the fs_cs macro to work.

The two possible values for fs_magic are FS_MAGIC, the default magic number for an HFS file system with a fixed-size directory format that limits file name length to DIRSIZ (14), and FS_MAGIC_LFN, the magic number of a file system using a variable-size directory format that supports file names of up to MAXNAMLEN (255) characters in length.

Super Block for a File System:

MAXBPC bounds the size of the rotational layout tables and is limited by the fact that the super block is of size SBSIZE. The size of these tables is inversely proportional to the block size of the file system. The size of the tables is increased when sector sizes are not powers of two, as this increases the number of cylinders included before the rotational pattern repeats (fs_cpc). The size of the rotational layout tables is derived from the number of bytes remaining in (struct fs).

MAXBPG bounds the number of blocks of data per cylinder group, and is limited by the fact that cylinder groups are, at most, one block. The size of the free block table is derived from the size of blocks and the number of remaining bytes in the cylinder group structure (struct cg).

inode:

The inode is the focus of all file activity in the HP-UX file system. There is a unique inode allocated for each active file, each continuation inode, each current directory, each mounted-on file, text file, and the root. An inode is ``named'' by its device-and-i-number pair. For the format of an inode and its flags, see inode(4).

DEPENDENCIES

Series 700

Series 700 systems support only one section per volume. Thus, there can only be one file system on each volume and the first 8 Kbytes of a file system is the boot area. This area contains the LIF volume header, the directory that defines the contents of the volume, and the bootstrapping program.

AUTHOR

fs was developed by HP and the University of California, Berkeley.

SEE ALSO

inode(4), lif(4).

© Hewlett-Packard Development Company, L.P.