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Software License Agreement
CAREFULLY READ THE FOLLOWING TERMS AND CONDITIONS BEFORE USING THIS PRODUCT. 
INSTALLATION INDICATES YOUR ACCEPTANCE OF THESE TERMS AND CONDITIONS. PROMPTLY 
REMOVE ALL FILES RELATED TO THIS PRODUCT FROM YOUR HOST PLATFORM SHOULD YOU 
DISAGREE WITH ANY OF THE TERMS OR CONDITIONS LISTED BELOW.

1. “Software” shall mean the digitally encoded, machine-readable data and program. The term “Software 
Product” includes the Software identified on the distribution media and any accompanying documentation. 
The term “Distribution Media” refers to any method by which the Software Product is delivered to the end 
user, including but not limited to Floppy Disks, CD-ROM, Magnetic Tape and On-Line distribution via the 
Internet. The Software Product is licensed (not sold) to you, and Hewlett-Packard either owns or licenses 
from other vendors who own, all copyright, trade secret, patent and other proprietary rights in the Software 
Product.

2. You agree to accept a non-exclusive license to use the Software identified on the distribution media solely 
for your own customary business or personal purposes.

3. To protect the proprietary rights of Hewlett-Packard, you agree to maintain the Software Product and other 
proprietary information concerning the Software Product in strict confidence and to establish reasonable 
procedures regulating access to and use of the software.

4. You agree not to duplicate or copy the Software except that you may make one backup copy. You agree 
that any such copy shall contain the same proprietary notices as those appearing on the original.

5. You shall not sublicense, sell, lease, or otherwise transfer all or any portion of the Software Product 
separate from the printer(s), without the prior written consent of Hewlett-Packard.

6. You may not modify or prepare derivative works of the Software Product. You may not transmit the 
Software Product over a network, by telephone, or electronically using any means; or reverse engineer, 
decompile or disassemble the Software.

7. You may transfer the Software Product with the printer(s), but only if the recipient agrees to accept the 
terms and conditions of this Agreement. Your license is automatically terminated if you transfer the 
Software Product and printer(s).

8. This License shall continue until terminated. This license may be terminated by agreement between you 
and Hewlett-Packard or by Hewlett-Packard if you fail to comply with the terms of this License and such 
failure is not corrected within thirty (30) days after notice. When this License is terminated, you shall either 
return to the place you obtained them, or destroy, the printer and all copies of the Software and 
documentation.

9. Hewlett-Packard warrants that for ninety (90) days after delivery, the Software will perform in accordance 
with specifications published by Hewlett-Packard, and that the distribution media will be free from defects 
in material and workmanship. Hewlett-Packard does not warrant that the Software is free from all bugs, 
errors and omissions.

THE PARTIES AGREE THAT ALL OTHER WARRANTIES, EXPRESS OR IMPLIED, INCLUDING 
WARRANTIES OF FITNESS FOR A PARTICULAR PURPOSE AND MERCHANTABILITY ARE EXCLUDED.

10. Your exclusive remedy and the sole liability of Hewlett-Packard in connection with the Software is 
replacement of defective distribution media upon their return to Hewlett-Packard. Hewlett-Packard will not 
be liable for any loss or damage caused by delay in furnishing a Software Product or any other 
performance under this Agreement.

Hewlett-Packard does not warrant that the functions contained in the Software will meet your requirements or 
that the operation of the Software will be uninterrupted or error free.

Hewlett-Packard reserves the right to make changes and/or improvements in the Software without notice at 
any time.



IN NO EVENT WILL HEWLETT-PACKARD BE LIABLE FOR LOST PROFITS, LOST DATA, BUSINESS 
INTERRUPTIONS OR ANY OTHER DIRECT, INDIRECT, INCIDENTAL OR CONSEQUENTIAL DAMAGES 
ARISING OUT OF THE USE OF OR INABILITY TO USE THIS PRODUCT, EVEN IF HEWLETT-PACKARD 
HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, OR ANY DAMAGES CAUSED BY 
ABUSE OR MANIPULATION OF THE SOFTWARE. SOME STATES DO NOT ALLOW THE EXCLUSION OR 
LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, SO THE ABOVE 
LIMITATION MAY NOT APPLY TO YOU.

11. California law governs this Agreement.

12. Use, duplication or disclosure by the Government is subject to restrictions as set forth in the Rights in 
Technical Data and Computer Software clause at FAR 242.227-7013, subdivision (b) (3) (ii) or 
subparagraph (c) (1) (ii), as appropriate. Further use, duplication or disclosure is subject to restrictions 
applicable to restricted rights software as set forth in FAR 52.227-19 (c) (2).

YOU ACKNOWLEDGE THAT YOU HAVE READ THIS AGREEMENT, UNDERSTAND IT, AND AGREE TO 
BE BOUND BY ITS TERMS AND CONDITIONS. NEITHER PARTY SHALL BE BOUND BY ANY 
STATEMENT OR REPRESENTATION NOT CONTAINED IN THIS AGREEMENT. NO CHANGE IN THIS 
AGREEMENT IS EFFECTIVE UNLESS WRITTEN AND SIGNED BY PROPERLY AUTHORIZED 
REPRESENTATIVES OF EACH PARTY. BY INSTALLING THIS SOFTWARE PRODUCT, YOU AGREE TO 
ACCEPT THE TERMS AND-CONDITIONS OF THIS AGREEMENT.

Hewlett-Packard makes no representations or warranties of any kind regarding this material, including, but not 
limited to, implied warranties of merchantability and fitness for a particular purpose. Hewlett-Packard shall not 
be held responsible for errors contained herein or any omissions from this material or for any damages, 
whether direct, indirect, incidental or consequential, in connection with the furnishing, distribution, performance 
or use of this material. The information in this manual is subject to change without notice. 

This document contains proprietary information protected by copyright. No part of this document may be 
reproduced, copied, translated or incorporated in any other material in any form or by any means, whether 
manual, graphic, electronic, mechanical or otherwise, without the prior written consent of Hewlett-Packard.

COPYRIGHT  2000, HEWLETT-PACKARD CO.

All rights reserved. 
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1 Overview

The LineJet Printer Manager Software
The LineJet™ printer manager utility is a versatile and dynamic 
program. It allows you to organize all of the printers in your office 
remotely in a single database, download software and printer 
settings from a host computer with a single mouse click, and use 
a virtual operator's panel to configure printers in the same room 
or on the other side of the world.

Requirements
Running the LineJet printer manager software requires:

• a LineJet printer

• a host computer running Microsoft Windows 95, Windows 
98, Windows NT or Unix Solaris operating system

Before installing the software, the printer must be attached to the 
host system via a LineJet Print Server (Ethernet) interface. 
Refer to your printer User’s Guide for information on connecting 
interfaces.

Installing the Printer Manager
The printer manager can be obtained from the HP World Wide 
Web site at http://www.hp.com/go/lp_printers. Follow 
the on-screen instructions for downloading and installing the 
software.

For Windows 95/98/NT users: When the program completes its 
installation, you may get a message stating that a program icon 
was created in your Start menu. Actually, the program only 
creates a shortcut icon on your desktop. If you would like an icon 
in your Start menu, you will have to create it manually.
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Printer Setup
Printer Setup
Your printer uses the diagnostic port to communicate with the printer 
manager. The diagnostic port must be configured to interact with the 
Ethernet interface. Follow the instructions below to check the diagnostic 
port setting.

1. On the printer control panel, press the ON LINE key to take the printer 
off line.

2. Press the UP (↑) and DOWN (↓) keys at the same time to unlock the 
ENTER key.

3. Enter the Factory Menu by pressing the ↓, ↑, ← and → keys at the 
same time.

4. The PRINTER MGMT menu appears. Press the ↓ key until the 
“Diagnostic Port” option displays. (If the “Debug Ethernet” option is 
already marked with an asterisk (*), there is no action needed. Skip to 
step 6.)

5. Press the → key until the “Debug Ethernet” option appears. Press 
ENTER to select this option.

6. Press the UP (↑) and DOWN (↓) keys at the same time to lock the 
ENTER key.

7. Press the ON LINE key to put the printer back on line.
 7



Getting Started
Getting Started
This section provides a short tutorial on how to set up and access a printer 
using the printer manager utility. 

8. This tutorial assumes the host computer running the printer manager 
utility and the printer you want to access are connected by a network. 
You must know the printer’s IP Address and Port Number.

9. From your operating system, open the printer manager. A brief splash 
screen appears, then the main screen of the Printer Database, as 
shown in Figure 1.

Figure 1. Printer Database Main Window
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Getting Started
10. Double-click on the “New_Printer (A template)” icon. The Printer 
Properties window appears, as shown in Figure 2.

Figure 2. Printer Properties (Identification)

11. Assign a name to your printer. Click inside the Name(Unique) box and 
delete the words “New_Printer”. Type in “Tutorial”.

12. Assign a description to this printer. Click inside the Printer Description 
box and delete the words “A template”. Type in “My First Connection”.
 9



Getting Started
13. Click on the tab at the top of the window that reads, “Security.” The 
Printer Properties window changes to the Security screen. See Figure 
3.

Figure 3. Printer Properties (Security)

14. If this is the first time the printer manager is being used, it is likely that 
no passwords have been assigned to this printer. If you are unsure, 
contact your system administrator. 

• If no password is assigned, leave both password boxes empty. 

• If a User password is necessary to access this printer, input the 
password in the User Password box. 

• If a Supervisor password is necessary to access this printer, input 
the password in the Supervisor Password box, and check the box 
next to Supervisor Mode. 

In either case, an asterisk (*) character will appear in the box after each 
letter you type to preserve the password’s secrecy.
 10



Getting Started
15. Click on the tab at the top of the window that reads, “Connections.” The 
Printer Properties window changes to the Connections screen. See 
Figure 4.

Figure 4. Printer Properties (Connections)

16. The Connections screen contains two additional tabs, “Access Method” 
and “Network”. The Access Method you choose tells the printer 
manager how the host computer will communicate with the printer. For 
the Administration Package of the printer manager, “LineJet” is the only 
Access Method available.

17. Ignore the Download Mode and Download Timeout pull-down menus 
for now.
 11



Getting Started
18. Click on the Network tab at the top of the Printer Properties window. 
See Figure 5.

Figure 5. Network Options

19. Click in the IP Address box. Input the IP Address of the printer you want 
to access. Follow the format shown in Figure 5.

20. Leave the Port Number box set at 3001.

21. Leave the Time Out box set at 15 seconds.
 12



Getting Started
22. Click Apply. This closes the Printer Properties window and returns you 
to the Printer Database main screen. Your printer is now set up in the 
printer manager database.

Figure 6. Printer Database Main Window

23. You can try to access the printer’s virtual operator panel as a test to see 
if the information you input is accurate. Follow this procedure:

a. The "Tutorial (My First Connection)" icon should be highlighted in 
blue, as shown in Figure 6. If it is not highlighted, click on the icon 
once to select it.

b. From the menu bar at the top of the window, click on Applications.

c. From the pull-down menu, click on Operator Panel. If the setup 
procedure was successful, the printer’s virtual operator panel should 
appear (see page 36). Otherwise, an error message will appear in 
the Status and Error Log. In the event of an error message, contact 
your system administrator.
 13



2 Printer Database

Overview
When you start the printer manager, the first screen which 
appears is the Printer Database window. The Printer Database is 
the tool used to organize and control printers, configuration files, 
and download files. Figure 7 displays how the database looks 
when you begin the printer manager for the first time. 

Figure 7. Printer Database Main Window

Menu Bar Toolbar Database

Status and Error Log
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Overview
NOTE:The first time you start the printer manager, you may get 
the error message, “Printer Database Not Found.” This 
error occurs because there is no database file specified 
as the default. To specify a default database in the 
Preferences menu, see page 31.

The Menu Bar contains all the menus which are used to control 
the functions of the program. The menus will be described in 
detail later in this chapter.

The Toolbar contains iconized shortcuts of the most commonly 
used menu functions. See page 19 for descriptions of the 
Toolbar icons.

The Database is the heart of the program, where you will access 
and control all of your printers in a tree format. The first line of 
the database tree displays the database file name. In Figure 7, 
the file name for this database is new.pdb. From there, your 
database tree will branch out to include printers, folders, 
configuration files and download files, which may be organized in 
groups; with a single mouse click, a file can be downloaded to 
several printers at once. In addition, you may use as many 
databases with the printer manager as you wish; databases can 
be saved as .pdb files on your local hard drive. Only one printer 
database may be opened at a time.

The Status and Error Log will scroll status and error messages 
as you work through the program. If the printer manager is not 
functioning properly, be sure to look at this window for any error 
messages which may appear. Use the scroll bar on the side of 
this window to reference previous status and error messages. 
The status and error messages relate to the current printer 
manager session, not to the specific database. When you close 
the printer manager, these messages will not be saved.
 15



Defining Printer Properties
Defining Printer Properties
Before using any of the applications of the printer manager, you 
must define the printer’s properties, which includes identifying 
the printer and configuring how the printer communicates with 
the printer manager. To define a printer, double-click on the 
printer’s name in the Printer Database. The first time you run the 
program, you will double-click on “New_Printer (A template)”. 
This will bring up the Printer Properties window. (See Figure 8.)

Figure 8. Printer Properties

The Printer Properties contains three tabbed windows, which are 
described below.
 16



Defining Printer Properties
Identification Tab

Name (Unique)/Printer Description — Assigns a name to your 
printer, which identifies it in the Printer Database. You may also 
assign a longer description, which appears in parentheses to the 
right of the printer name in the database. In assigning a printer 
name, be sure to use only the alphanumeric characters A-Z, a-z 
and 0-9 (underscores and spaces may be used to separate 
words in your descriptions).

Security Tab

User/Supervisor Password — Enter the printer's password, if 
appropriate. The password feature is used to restrict access to 
certain functions of the printer manager. In User mode, the 
printer manager does not allow the following functions: files, 
configurations or configuration names to be downloaded to the 
printer, clearing the error log, and setting passwords. Supervisor 
mode allows unrestricted access to all functions of the printer 
manager. Passwords are only recognized up to 9 characters, 
and are displayed as *****, one * for each character typed. To set 
up a password, see page 35.

Connections Tab

The connections screen contains two sub-tabs: The Access 
Method tab and the Network tab.

Access Method Tab

Access Method — Identifies how the printer manager accesses 
the printer. For the Administration Package, “LineJet” is the only 
option available. See the LineJet Print Server User’s Guide for 
information on setting up the LineJet Print Server for your printer.

Download Mode — Identifies how the printer manager 
downloads files and configurations to the printer. For the 
Administration Package, “Access Method” is the only option 
available. All downloads will be made using the LineJet Print 
Server interface.
 17



Defining Printer Properties
Download Timeout — Specify the amount of time, in minutes, 
the printer will wait for a response from the printer manger after 
sending a file to be downloaded from the host computer. If there 
is no response in the specified amount of time, the printer will 
time out and the download is terminated. If you have a slow 
connection between the printer manager and the printer, you 
may want to define a longer Download Timeout period. Define 
the Download Timeout between 1 and 60 minutes (1 minute is 
the default).

Network Tab

Enter the printer's IP Address and Port Number. (Click on the 
“Default” button to reset the Port Number to 3001.) The Time Out 
option sets the amount of time, in seconds, the printer manager 
will wait for a response from the printer after sending a 
command. If there is no response in the specified amount of 
time, an error message appears in the Status and Error Log 
window. If you have a slow connection between the printer 
manager and the printer, you may want to define a longer Time 
Out period. Define the Time Out between 5 and 300 seconds (15 
seconds is the default).

NOTE:The Network settings must match the settings in the 
printer's front panel menu. See the “ETHERNET 
PARAMS" section in the User’s Guide.
 18



Toolbar
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Toolbar
The printer manager toolbar contains a series of icons which 
serve as shortcuts to certain actions in the program. The function 
of these icons is shown in Figure 9. Refer to the specified page 
for a detailed description of each function. 

Figure 9. Toolbar

. . .

. . .

Insert Folder 
(page 21)

Insert Printer 
(page 21)

Insert Configuration 
File (page 21)

Insert Download 
File (page 21)

Cut
(page 21)

Copy 
(page 21)

Paste: Same 
Level (page 22)

Paste: One 
Level Below 

(page 22)

Delete
(page 2

Edit selected 
database entry 

(page 21, step 3.)

Include/Exclude 
(page 22)

Operator Panel 
(page 36)

Information Capture 
(page 39) File 

Download 
(page 23)

Show status of all 
printers (page 34)

Show status o
selected printer

(page 34)

Configuration Editor 
(page 41)

Configuration File 
Download (page 23)
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Managing the Database
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Managing the Database
You can organize your databases easily and effectively using the 
Edit option on the Printer Database menu bar. You may add, 
delete and assign printers, configuration files and download files 
to your database tree and keep them all organized using folders. 
All of the functions in the Edit Menu have shortcut keys on the 
toolbar (see page 19).

Database Items

The Edit Menu

Figure 10. The Edit Menu

Use the Edit option on menu bar to build your database. The 
options in the Edit menu are described below.

Printer. See “Defining Printer Properties” on page 16.

Folder. Use folders to group the elements of your database.

Download file. A file stored on your host computer (i.e. software
which you can assign to be downloaded to the non-volatile 
memory of a printer or group of printers.

Configuration file. A file created in the Configuration Editor (see
page 41) which is stored on your host computer. A configuration
file contains user-defined printer configurations which can be 
downloaded to your printer using either the Printer Database or
the Configuration Editor.
 20



Managing the Database
Insert
Adds a folder, printer, configuration file, or download file into your 
database. An existing database item must be selected in order 
for a folder, printer, or file to be created. You may also paste the 
contents of the paste buffer (the last item which was copied or 
cut) into the database. The new icon will be placed one level 
below the selected database item. If there are already items 
below the selected database item, the new item will be placed at 
the end of the line. 

The Insert menu is also used to create a LineJet Locator folder 
or a Subnet mask. For more information on these utilities, see 
“Locating Printers on a Network” on page 28.

Inserting an item involves a three-step process: 

1. Select a database item. The new icon will be created below 
the item you select.

2. Define which type of icon you wish to add by clicking Edit → 
Insert → and then selecting the item you are adding. This 
creates the new icon on the database. 

3. Define what printer, folder or file this icon will represent. 

a. To define a printer, see “Defining Printer Properties” on 
page 16.

b. To define a folder, double-click on the “New Folder” icon 
you created in step 2. A dialog box will open. Type the 
name you want to give this folder and click Apply.

c. To define a configuration or download file, double-click on 
the “New Config File” or “New Download File” icon you 
created in step 2. A File dialog box will open. Find the 
appropriate configuration or download file, select it, and 
click Open. The database will display the name of the 
configuration or download file, as well as the file path.

Cut
Removes a selected folder, printer or file from the database and 
copies it to the paste buffer.

Copy
Copies a selected folder, printer or file from the database to the 
paste buffer, leaving the original intact.
 21



Managing the Database
NOTE:The printer manager will cut or copy only one database 
item at a time. If multiple database items are selected 
using the SHIFT key and then cut or copied, only the first 
selected database item will be copied to the paste buffer.

Paste

Places all items in the paste buffer back on the database tree. A 
database item must be selected in order to paste. The pasted 
item will be placed on the same level as the selected database 
item. 

NOTE:If you use the Edit → Paste option, the pasted item will 
be placed on the same level as the selected database 
item. If you use the Edit → Insert → Paste Buffer option, 
the pasted item will be placed one level below the 
selected database item. Please note the difference.

Delete

Permanently removes a selected folder, printer or file from the 
database.

Include/Exclude

Places a selected folder, printer or file in an inactive state. 
Inactive database items are not affected by actions performed 
under the Applications menu, Status menu, or Utilities menu. 
Inactive database items will display a red circle with a slash 
through it on top of the item’s icon.

To reactivate a database item, select the inactive item and click 
Edit → Include/Exclude.
 22



Managing the Database
Downloading Files

Once you have defined configuration and download files on your 
database, you must download them to your printer in order for 
them to affect the active print state. Use the Printer Database to 
download as many files to as many printers as you want.

NOTE:Each emulation used by the printer has its own list of valid 
flash files it can use. Refer to the appropriate Technical 
Reference Manual for details about valid flash files.

To download a  file which is on the same level or one level 
lower than the target printer on your database tree, select the 
printer which will receive the download and click Applications 
→ Configuration Download. To download a   file which is on 
the same level or one level lower than the target printer on your 
database tree, select the printer which will receive the download 
and click Applications → File Download. 

Once you have chosen your downloading option, a dialog 
window opens which shows all the files being downloaded to 
each printer. Confirm that the correct files are being sent to the 
appropriate printers. Click Upgrade to begin the download. Click 
Cancel to cancel the download and start over. 

You may also download a series of files to several printers at 
once using folders. By selecting a folder and choosing either 
Applications → Configuration Download or Applications → 
File Download, all of the appropriate files inside that folder will 
be downloaded to all of the printers inside that folder.

NOTE:Downloading a configuration does not immediately 
update the printer’s active configuration. A downloaded 
configuration must be activated using the “Load Config.” 
setting in the printer's operator panel. See your printer's 
User’s Guide for details.

See page 24 for examples of using the Printer Database to 
download files.
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Managing the Database
Downloading Files Examples
Figure 11 shows a sample database. 

Figure 11. Sample Database
 24



Managing the Database
In the sample database, the printers are organized into Buildings 
A and B. Inside the Building A folder, the printers in the 
Manufacturing and Administration areas have been separated 
into sub-folders and given their own download and configuration 
files. The Conference Room printer also has its own 
configuration file. Two of the printers from Building A require 
special fonts, so those printers have been duplicated in the 
Special Fonts folder, along with the file which contains those 
fonts. The Building B printers are not listed because that folder is 
collapsed.

Example 1

The user of the sample database selects the Conference Room 
printer, then clicks Applications → Configuration Download. 
The following dialog box appears:

The dialog box displays the printer receiving the file, the name of 
the file being sent, the progress of the download, and the 
configurations contained within the file. According to the dialog 
box, the Conference Configs.cfg file contains a factory 
configuration as well as two user-defined configurations. When 
the user clicks on Upgrade, the Conference Configs.cfg 
file is sent to the Conference Room printer. The dialog box 
indicates the progress of the file as it downloads.
 25



Managing the Database
Example 2

The user of the sample database selects the Manufacturing 
folder, then clicks Applications → Configuration Download. 
The following dialog box appears:

The printer manager will send all configuration files inside the 
Manufacturing folder to all printers inside the Manufacturing 
folder. According to the dialog box, when the user clicks on 
Upgrade, the Manufacturing Configs.cfg file will be sent 
to printers Area 1 and Area 2.

You may also specify which configurations within the file you 
wish to download. Double-click on the name of the printer you 
want to make adjustments to, and a dialog box appears which 
allows you to select or deselect specific configurations. Only the 
selected configurations will be downloaded.

Notice that the software file inside the Manufacturing folder, 
Printer Software A.prg, is not on the download list. The 
printer manager downloads configuration files and download 
files separately. If the user also wanted to download the 
Printer Software A.prg file to these printers, they would 
select the Manufacturing folder, then click Applications → File 
Download.
 26



Managing the Database
Example 3

The user of the sample database selects the Building A folder, 
then clicks Applications → File Download. The following dialog 
box appears:

Selecting a folder not only downloads files from that folder, but 
all of its sub-folders as well. According to the dialog box, once 
the user clicks on Upgrade, the Printer Software A.prg 
file will be sent to printers Area 1 and Area 2; the Printer 
Software B.prg file will be sent to the Vending Room and 
Conference Room printers; and the Fonts.fnt file will be sent 
to the Area 1 and Vending Room printers.

The options in the Download Mode column may be changed. 
Double-click on the printer you wish to change to toggle through 
the following options:

Download w/Configuration — When the firmware file is 
downloaded, the configurations currently saved in non-volatile 
memory are preserved.

Download — When the firmware file is downloaded, all the 
configurations are reset to their original, factory settings.

Skip — As the printer manager moves through the Download 
queue, any files marked “Skip” are not downloaded.
 27



Locating Printers on a Network
Locating Printers on a Network
The printer manager includes a utility which polls all the printers 
on your network and returns information about those printers to 
the printer manager database screen. You may also set up 
Subnet Masks to limit the number of printers the printer manager 
searches for. This is a quick and effective way to set up your 
database with all the appropriate information you need about the 
printers on your network.

Before searching for printers, you must set up the search 
structure. Click on Edit → Insert → LineJet Locator. This 
creates a folder called “LineJet Locator”, which is the engine that 
searches for the printers on the network. Underneath the 
“LineJet Locator” folder, another folder is created called 
“Network Topology”. This is the default name; to change the 
name of this folder, double-click on it. Inside the “Network 
Topology” folder, a default Subnet is created, which has the 
network I.D., network mask and gateway information displayed 
right in the database.

Figure 12. Inserting a LineJet Locator
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Locating Printers on a Network
To change the information in the Local Subnet, double-click on it. 
You are able to change the Subnet Name, Network I.D., Network 
Mask and Gateway information.

You may also place additional Subnets inside the database. 
Click on the folder or database item you wish to place the subnet 
underneath, then click on Insert → Subnet.

Once you have set up the appropriate Subnet information, you 
are ready to search for printers. Click on Utilities → Search for 
LineJet Printers. All the printers under the Subnet you set up 
will appear in the database in a “Located LineJet Printers” folder 
located underneath the “LineJet Locator” folder.

Figure 13. Printer Search Results

The database shows the name, MAC address, IP Address and 
group name of each printer found. Double-click on the printer 
icon to change the Printer Properties (see “Defining Printer 
Properties” on page 16).
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Printer Database Menu Bar

The Printer Database menu bar is located at the top of the main 
window (see page 14). Use the menu bar to access all the 
functions of the printer manager.

The following are descriptions of each of the options located in 
the menu bar.

File

New — Creates a new database file. The printer manager only 
allows one database file to be open at a time. The printer 
manager will ask if you want to save your changes to the current 
database before creating a new one.

Open — Opens a database file. The printer manager only allows 
one database file to be open at a time. The printer manager will 
ask if you want to save your changes to the current database 
before opening a different one.

Save — Saves the active database file under its current name.

Save As — Prompts the user to enter a name for the current 
database file before saving. Use Save As if you do not wish to 
overwrite the current database file.

Preferences — Opens the Preferences dialog box. (See Figure 
14.)

Exit — Exits the printer manager. 
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Figure 14. Preferences (Printer Database tab)

The Preferences dialog box has two tabs. 

The Printer Database tab controls database features.

• Database File Name — Enter the name of the default 
database file. This is the database file the printer manager 
opens when the program starts. To select a new default 
database file, type it into the Database File Name box, or 
click on “Browse” to find a file on your network.

• Show message when a printer is not protected. — Check 
this box to enable a warning message which informs the user 
when a selected printer does not have an assigned 
password. 
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Figure 15. Preferences (Configuration Editor tab)

The Configuration Editor tab controls features of the 
Configuration Editor utility.

• Hide Key/Unhide Key — Assigns which keys will hide and 
unhide menu items in the Configuration Editor menu tree 
(see page 45). The default for Hide is “H h”. The default for 
Unhide is “U u”.

• Dec./Inc. Key — Assigns which keys will decrement and 
increment menu items in the Configuration Editor menu tree 
(see page 43). The default for decrement is “< ,”. The default 
for increment is “> .”.

• Max Revs. — Set the maximum allowed number of reverted 
Configuration Editor sessions to be saved by the printer 
manager. For detailed information on the Revert feature, see 
page 48. The Max Revs. setting ranges from 1-20. The 
default setting is 10.
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Edit

For a detailed explanation of the Edit menu, see page 20.

View

Top Level — Collapses all folders on the database menu tree.

Expand All — Expands all folders and printers on the database 
menu tree.

Applications

For a detailed explanation of the Applications menu options, 
find the menu option you are looking for in Table 1 and go to the 
referring page.

Table 1. Applications Menu options

Menu Option Page #

Operator Panel page 36

Information Capture page 39

Configuration Editor page 41

Configuration Download page 23

File Download page 23

Barcode Verification page 48
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Status

The Status Window is shown in Figure 16.

Figure 16. Status Window

Selecting any of the options in the Status menu brings up the 
Status window shown in Figure 16. The Status window displays 
the current status of the printer(s) you choose. Clicking 
Status → Selected Printers displays the printers currently 
selected in the Printer Database menu tree. Clicking Status → 
All Printers displays the status of all printers in the Printer 
Database menu tree.

Printers marked as inactive will not appear in the Status window.

In addition to printer status, this window allows you to turn the 
RibbonMinder™ gauge on and off by checking or unchecking the 
box next to the gauge for that printer. RibbonMinder is a feature 
which shows you when a ribbon should be changed by 
monitoring ribbon consumption and alerting you when the print 
quality falls below a level you designate. For more information 
about RibbonMinder, see your printer User’s Guide.
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Utilities

Reboot Printer — Reboots the selected printer.

Set Printer Password — The supervisor password must be 
entered in the Printer Properties (see page 16) before the 
program will allow any passwords to be changed. 

A dialog box appears, requesting a new password. Type in the 
new password and click Set. To delete a password, type in the 
current password and click Delete. 

Search for LineJet Printers — Searches the network for 
printers currently connected with the LineJet Print Server 
interface. See “Locating Printers on a Network” on page 28 for a 
detailed description of this utility.

Help 

About — Displays the splash window seen when the printer 
manager was started.
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3 Applications

Operator Panel

The printer manager includes a virtual operator panel which 
simulates all the functions of the actual operator panel on your 
printer. Figure 17 shows the virtual operator panel.

To access the operator panel, select the appropriate printer from 
the Printer Database and click Applications → Operator Panel.

Figure 17. Operator Panel

Primary Operator Keys

Disabled/In Progress Indicator

econdary Operator Keys

Operator Panel Window

Message Display

Status Indicator
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Primary/Secondary Operator Keys

Clicking on the primary and secondary operator keys in the 
virtual operator panel causes the printer to perform the same 
actions as if you were physically pressing the keys on the actual 
operator panel. For example, when the printer is on line, clicking 
on the ON LINE key takes the printer offline. Clicking on the ON 
LINE key again places the printer back on line. 

Some functions require pressing multiple keys at the same time. 
You can do this with the virtual operator panel by holding down 
the SHIFT key on your computer keyboard as you select each 
key. When you release the SHIFT key, the selected keys on the 
operator panel activate as if they were pressed simultaneously. 
For example, unlocking the ENTER key on your printer requires 
that you press UP and DOWN at the same time. To do this with 
the virtual operator panel, hold down the SHIFT key on your 
keyboard, then select UP and DOWN with your mouse. Release 
the SHIFT key, and the ENTER key is unlocked.

Some functions require pressing keys for differing periods of 
time. For example, in offline mode, pressing and releasing the 
LF key quickly on the printer’s operator panel performs a line 
feed; pressing and holding the LF key for more than a second 
advances the paper continuously. The same is true for the virtual 
operator panel. If you click and release on the LF key quickly 
with your mouse, the printer performs a line feed. If you click and 
hold the key down with your mouse for longer than a second, the 
LF key turns a different color and advances the paper until you 
release the key. 

NOTE:For a detailed explanation of the functions of each 
primary and secondary operator key, see your Quick 
Reference Guide.

Message Display

The message display shows what is currently displayed on the 
printer’s LCD. Use the message display to configure menu 
options and read fault messages.
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Status Indicator

The status indicator displays the printer’s current operating 
mode:

Online mode — The indicator lights up.

Offline mode — The indicator is greyed out.

Fault mode — The indicator flashes.

Disabled Indicator

Normally, when you are using the printer via the virtual 
operator’s panel, the “Disabled” light is off, and the “Enable” 
button underneath the status indicator is grayed out. While the 
printer manager has control of the printer, the message 
“CAUTION PPM HAS REMOTE CONTROL” appears on the 
actual printer’s LCD display to alert any other users that the 
printer is currently being used remotely.

However, if another user physically presses any key on the 
actual printer, this command overrides the virtual operator panel 
and disables it. The “Disabled” indicator lights up, and the 
“Enable” button becomes active. Pressing the “Enable” button 
gives control of the printer back to the virtual operator panel.

In Progress Indicator

This light flashes when the printer is working on a job or moving 
paper.
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Information Capture

To access the Information Capture application, select the 
appropriate printer from the Printer Database and click 
Applications → Information Capture.

Figure 18. Information Capture

The Information Capture application allows you to view any of 
the configurations or error logs saved in the printer’s non-volatile 
memory and save them as a text file to your local hard drive. 

Loading a configuration into the Information Capture will NOT 
change the active configuration — this is a view only application. 
If you wish to make any changes to your configurations, use the 
Configuration Editor (see page 41).

The display at the bottom of the Information Capture window 
shows the total number of text lines in the current capture, as 
well as which complete text line in the capture appears at the top 
of the window (First) and at the bottom of the window (Last).
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The following are descriptions of the Information Capture menus.

File

Save As — Saves the configuration or error log currently 
displayed in the Information Capture window as a .log file on 
your local hard drive. This .log file can then be opened in any 
word processing program.

Clear Window — Clears the Information Capture window of any 
displayed configurations or error logs.

Close — Closes the Information Capture window.

Configuration Printout

Current/Factory/Power-Up/All/1-8 — Choose which 
configuration you wish to view. If you choose more than one 
configuration without clearing the window, each additional 
configuration is added to the end of the display.

Error Log

All Errors — Displays the printer's current error log.

Clear — Clears the printer's non-volatile memory of all errors.

NOTE:The printer's error log and the Status and Error Log seen 
at the bottom of the main printer database window of the 
printer manager are separate. Clearing the printer's error 
log does not clear the Status and Error Log.

Directory

Flash File System — Displays the file system information for 
your printer.
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Configuration Editor

To access the Configuration Editor application, select the 
appropriate printer from the Printer Database and click 
Applications → Configuration Editor. The active configuration 
is uploaded from the printer and displayed in the Configuration 
Editor window. (See Figure 19.)

Figure 19. Configuration Editor 

The Configuration Editor allows you to upload, modify and 
download eight user-defined configurations and the factory 
default configuration (if modification of the factory configuration 
has been enabled; see the Note on page 43). You may also save 
sets of configurations to your local hard drive so they can be 
easily downloaded to the printer at any time. 

The Configuration Editor does not effect the current configuration 
or the active printer status until the configurations are 
downloaded to the printer.
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Menu Tree

The Configuration Editor displays the printer configurations in a 
tree format (see Figure 19). The top level of the tree is the 
OFFLINE menu. From that level, the tree branches into the 
printer’s submenus. Menu items which have a box with a plus (+) 
or minus (-) sign next to them have further submenus below 
them. Click on the plus sign to expand the submenus below. 
Click on the minus sign to collapse the submenus. (You may 
also use the Expand Tree/Collapse Tree options in the View 
menu to expand or collapse submenus.)

There are three pull-down menus at the bottom of the 
Configuration Editor. The Displayed Language option allows 
you to select from five different languages in which to display the 
configuration information. The Displayed Configuration option 
lets you easily choose between the available configurations to 
display. The Power-Up Configuration allows you to assign 
which configuration will be loaded whenever the printer is turned 
on.

Creating Configurations

Along with the factory configuration, your printer allows up to 8 
user-defined configurations which can be downloaded to your 
printer’s non-volatile memory. You may create configurations 
using the printer’s operator panel, or by using the Configuration 
Editor. 

To create a configuration using the Configuration Editor:

1. Click Edit → Copy From:. A list of configurations appears. 
Undefined configurations will appear grey. Choose one of the 
existing configurations.

2. Click Edit. (Notice that the configuration you chose in step 1 
now appears next to the Copy From: menu item.) Move your 
mouse down to Copy To. A list of configurations appears. 
Choose the number of the configuration you wish to create. 
This new configuration will be created with the settings from 
the configuration you chose in step 1.

NOTE:If you choose to Copy To a configuration which already 
exists, that configuration will be overwritten.
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3. You may now edit the configuration settings. See the next 
section, “Changing Configurations”.

Changing Configurations

There are two ways of changing configuration settings in the 
Configuration Editor: 

• making the changes directly on the menu tree

• using the Menu Editor

NOTE:Normally, the factory default configuration cannot be 
changed. However, you may enable modification of the 
factory configuration by selecting Edit → Enable Factory 
Edit. It is strongly recommended that you do not modify 
the factory default configuration. To disable modification 
of the factory configuration, select Edit → Disable 
Factory Edit.

Making Changes on Menu Tree

1. Using the “Displayed Configuration” menu at the bottom of 
the window, use the pull-down arrow to choose the 
configuration to be changed.

2. Expand the submenus until the configuration setting you wish 
to change is displayed.

3. Select the menu item you wish to change. A selection box 
surrounds your choice.

4. Use the < and > keys to toggle through the available options. 
(You may change these keys in the File → Preferences 
screen of the Printer Database window. See page 31.)
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Menu Editor

Double-clicking on any menu item brings up the Menu Editor 
window. In Figure 20, below, the user has double-clicked on the 
Printer Protocol option.

Figure 20. Menu Editor (Line Matrix)

By using the Menu Editor, you may view and adjust the settings 
of all nine of the printer configurations at the same time. To 
change any setting, click on the pull-down arrow underneath the 
appropriate configuration and choose the option you want. If a 
configuration does not exist yet, its name and settings are 
grayed out; you must create the configuration before you can 
edit it (see page 42).

Select the Hidden button under any configuration to hide this 
menu item in the operator panel. Select the Hide All button to 
hide this menu item in all configurations. (For more information 
on hiding, see page 45.)
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Select Copy (Fact, #1-8) to set all configurations to the same 
value as the factory or user-defined configuration currently 
selected under the Edit → Copy From: menu in the 
Configuration Editor (see page 42).

Select Cancel to exit the Menu Editor without saving your 
changes.

Select Apply to save your changes without exiting the Menu 
Editor.

Select OK to save your changes and exit the Menu Editor.

Deleting Configurations

To delete any of the configurations (except the Factory Config.), 
select Edit → Delete → and choose the number of the 
configuration to be deleted.

Naming Configurations

You may give a 15-character alpha-numeric name to any of the 8 
user-defined configurations. Click Edit → Names to bring up the 
Edit Configuration Names window.

Choose the configuration you want to name, then click Apply to 
assign the names you have changed, Cancel to exit this window 
without saving your changes, or Reset to restore the original 
configuration numbers.

Hiding/Unhiding Menu Items

In order to reduce the complexity of the operator panel menus, or 
allow printer operators to change only certain printer 
configuration menu items, the Configuration Editor gives you the 
option of hiding menus. If you choose to hide a menu item in the 
Configuration Editor, that menu item will still affect the printer 
when the configuration is downloaded to it, but it will not appear 
on the printer’s front panel.

The Configuration Editor displays hidden menus in gray on the 
menu tree. When a menu item is hidden, all of its sub-menus are 
hidden as well. In Figure 21, the Printer Protocol menu item has 
been hidden. The Printer Protocol menu item, as well as its sub-
menus (P-Series, P-Series XQ, etc.) will be unavailable to 
anyone attempting to change this configuration on the printer’s 
operator panel.
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Hidden menu items may still be changed using the Menu Editor.

Figure 21. Hidden Menu Items

There are three methods for hiding or unhiding menu items:

1. Using the keyboard. From the menu tree, select the 
appropriate menu item. A selection box appears around the 
selected menu item. Press the H key to hide the menu item or 
the U key to unhide the menu item. (You may change these 
keys in the File → Preferences screen of the Printer 
Database window. See page 31.)

2. Using the Menu Editor. See page 45.

3. Using the Hide option on the Configuration Editor menu bar. 
Using this menu option, you may hide or unhide individual 
items, sub-menus or the entire configuration.
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Saving Configuration Files

Normally, your printer is limited to the nine configurations it 
saves in its non-volatile memory. Any changes to these 
configurations would be made through the printer’s operator 
panel. The advantage to using the printer manager to manage 
your configurations is you may store a nearly unlimited number 
of configurations on your host computer. 

Once you have made all of your changes, you may save your 
configurations as a .cfg file on your local hard drive. This way, 
you may choose to open any set of configurations from your host 
computer and download them into your printer quickly and 
easily.

To save configurations to your local hard drive, click File → 
Save As. You will be prompted to enter a file name. Be sure to 
save your configurations as a filename.cfg file.

Opening Configuration Files

To open a configuration file, click File → Open. The 
Configuration Editor loads the settings from the file you choose. 

Remember, these settings will not affect the current 
configuration or the active printer status until the configurations 
are downloaded to the printer.

NOTE:The Configuration Editor displays one configuration file at 
a time. Be sure to save any changes before opening a 
different configuration file.

Downloading Configurations

You may use the Configuration Editor to download any 
configurations you have created into your printer. Open the 
configuration file you wish to use, then use the options under the 
Download menu to send individual configurations, all 
configurations, or just the configuration names.

Downloading a configuration deletes the corresponding 
configuration currently stored in the printer. If you wish to save 
the configurations currently stored in the printer before 
overwriting them, upload them into the Configuration Editor first 
and then save them as a .cfg file on your local hard drive.
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Barcode Verification
Revert

The Configuration Editor contains a special feature which allows 
you to revert to a previously uploaded printer configuration.

Each time you start the Configuration Editor, the current 
configuration settings are uploaded from your printer’s non-
volatile memory. The Configuration Editor saves this information, 
and assigns a date and time to it. 

Click on File → Revert, and you will be presented with a list of 
previous Configuration Editor sessions. Choosing the date/time 
stamp of any session restores the configuration settings which 
were uploaded from the printer at that time. 

You may set the maximum number of revert sessions allowed in 
the File → Preferences screen of the Printer Database window. 
The default is 10.

Barcode Verification
The Barcode Verification application is currently not available for 
line matrix printers.

Configuration Download/File Download
For a detailed explanation on how to download configurations 
and files using the Printer Database, see page 23.
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