HPlogo HP-UX Reference > P

pfs_mount(1M)

OBSOLETED
HP-UX 11i Version 2: December 2007 Update
» 

Technical documentation

 » Table of Contents

 » Index

NAME

pfs_mount, pfs_umount — mount and unmount CD-ROM file systems

SYNOPSIS

pfs_mount [-v -a]

pfs_mount [-v -a -f -n] [ -t type ] [ -x xlat ] [ -o options ] filesystem directory

pfs_mount [-v -a -f -n] [ -x xlat ] [ -o options ] filesystem | directory

pfs_umount [ -v -a -c ] filesystem | directory

DESCRIPTION

pfs_mount attaches a named filesystem to the file system hierarchy at the pathname location directory, which must already exist. If directory has any contents prior to the pfs_mount operation, these remain hidden until the filesystem is once again unmounted. If filesystem is of the form host:pathname , it is assumed to be a remote file system.

In the case of a local mount, pfs_mount probes the specified character device to determine the file system type. It then contacts the local pfs_mountd.rpc program to register the specified directory as a valid mounted file system. pfs_mountd.rpc will reply with the address of the pfsd.rpc who will be handling all requests for files on that directory.

Remote mounts are very similar, except that both the local and remote mount daemons will be contacted. The remote mount daemon will supply the PFS server address, and the local mount daemon will be contacted to register the mount.

pfs_umount unmounts a currently mounted PFS file system, which can be specified as either a directory or a filesystem.

pfs_umount contacts the local mount daemon to determine what actions should be taken to perform the unmount. If the file system was originally remotely mounted, the remote mount daemon is informed of the unmount, and the file system is unmounted. Otherwise, it is simply unmounted.

pfs_mount and pfs_umount maintain a table of mounted file systems in /etc/pfs_mtab, described in pfs_fstab(5). If invoked without an argument, pfs_mount displays the contents of this table. If invoked with either a filesystem or a directory only, pfs_mount searches the file /etc/pfs_fstab for a matching entry, and mounts the file system indicated in that entry on the indicated directory.

If a user unmounts a PFS file system with the umount program, or interrupts the pfs_umount program before it has completed processing, the PFS daemons may leave the mount device open after the file system is no longer accessible. To clear these problems, use the -c flag for pfs_umount.

PFS expects a character device to be used for mounts, not a block device. Use of a block device with PFS is not supported.

pfs_mount Options

-v

Verbose. Display a message indicating each file system being mounted.

-a

All. Mount all file systems described in the /etc/pfs_fstab file.

-f

Fake an /etc/mnttab entry, but do not actually mount any file systems. Note: This option has no effect on HP-UX 10.30 or later.

-n

Mount the file system without making an entry in /etc/mnttab. Note: This option has no effect on HP-UX 10.30 or later.

-x xlat

Filename translation options. Any combination can be specified, although some combinations do not make sense (i.e. dot_version and no_version).

no_version

will suppress the printing of the version number (and semicolon) at the end of ISO 9660 and High Sierra filenames.

dot_version

replaces the version number (and semicolon) with a period followed by the version number.

lower_case

Converts upper to lower case on all file (and directory) names.

unix

Shorthand for no_version and lower_case.

-t type

Force the CD-ROM to be mounted as the specified type, if possible. Accepted types are:

iso9660

will cause the mount program to attempt to mount the CD-ROM image using the ISO 9660 specifications. If the CD image is not ISO 9660 compatible, the mount fails. Note that if the CD image is also Rock Ridge compliant, and the -t iso9660 option is not specified, the CD-ROM image will be mounted with Rock Ridge extensions enabled.

hsfs

will cause the mount program to attempt to mount the CD-ROM image using the High Sierra specifications. If the CD image is not hsfs compatible, the mount fails.

rrip

will cause the mount program to attempt to mount the CD-ROM image using the Rock Ridge Interchange specifications. If the CD image is not RRIP compatible, the mount fails. Note, that if the CD-ROM image supports the Rock Ridge Interchange Protocol, and the CD-ROM image is mounted with rrip, the translation options are suppressed.

Note that these get entered into the /etc/pfs_mtab and /etc/pfs_fstab with a pfs- preceding the type.

-o options

Specify file system options as a list of comma-separated words from the list below.

options valid on all file systems:

ro

Even if not specified, the read-only option is implied.

suid|nosuid

SetUID execution allowed or disallowed.

bg|fg

If the first attempt fails, retry in the background, or, in the foreground.

retry=n

The number of times to retry the mount operation.

rsize=n

Set the read buffer size to n bytes.

timeo=n

Set the PFS timeout to n tenths of a second.

retrans=n

The number of PFS retransmissions.

soft|hard

Return an error if the server does not respond, or continue the retry request until the server responds.

intr

Allow keyboard interrupts on hard mounts.

The defaults are:

suid,fg,retry=10000,timeo=7,rsize=2048,retrans=3,hard

options specific to iso9660 and hsfs file systems:

xlat=xlat_flags

xlat_flags is a colon (:) separated list of translation options. Currently supported are no_version, dot_version, lower_case, and unix. They allow you to perform the same translations options the -x flag does. The -x flag remains for backward compatibility. It is suggested that you use the xlat= option flag as they can be placed in the /etc/pfs_fstab file.

pfs_umount Options

-v

Verbose. Display a message indicating each file system as it is unmounted.

-a

All. Unmount all PFS mounted file systems.

-c

Close. Instruct the PFS daemons to close the given file system, but do not attempt to umount the file system. This is useful when the file system has already been unmounted, but the PFS daemons still have the source character device open.

pfs_mount CONFIGURATIONS

Background vs. Foreground

Filesystems mounted with the bg option indicate that pfs_mount is to retry in the background if the server's mount daemon (see pfs_mountd(1M)) does not respond. pfs_mount retries the request up to the count specified in the retry=n option. Once the file system is mounted, each PFS request made in the kernel waits timeo=n tenths of a second for a response. If no response arrives, the time-out is multiplied by 2 and the request is retransmitted. When the number of retransmissions has reached the number specified in the retrans=n option, a file system mounted with the soft option returns an error on the request; one mounted with the hard option prints a warning message and continues to retry the request.

Interrupting Processes With Pending PFS Requests

The intr option allows keyboard interrupts to kill a process that is hung while waiting for a response on a hard-mounted file system.

Attributes Cache

The server's attribute cache retains file attribute information on requests that have been made. This provides faster access to entries which have previously been decoded.

Lookup Cache

The Lookup Cache holds information about the sequential nature of the directory entries. This cache stores the location of the next directory entry. When a request comes in for a directory entry, if the preceding directory entry had been accessed earlier, this location is examined first to see if the directory entry being requested matches the directory entry at that location.

Block Cache

This cache holds raw 8k blocks of recently accessed data.

EXAMPLES

To mount a CD-ROM disk:

pfs_mount /dev/rdsk/c0t6d0 /cd-rom

To mount a remote file system:

pfs_mount serv:/cd-rom /cd-rom

To fake an entry for iso9660 on /cd-rom:

pfs_mount -f -t iso9660 /dev/rdsk/c0t6d0 /cd-rom

To hard mount a remote file system:

pfs_mount -o hard serv:/cd-rom /cd-rom

WARNINGS

PFS is obsolete and no longer supported on any HP-UX release. Delivery of PFS interfaces will be discontinued in the next HP-UX release.

PFS, from Young Minds, Inc. (now defunct), was originally adopted by HP to provide accessibility to Rock Ridge Interchange file system format on CD-ROM file systems. The equivalent functionality is now provided via the HP-UX CDFS file system type and HP-UX's standard file systems commands.

PFS has known functionality and performance problems. HP customers are urged to stop using the PFS interfaces, including these interfaces, pfs_mount and pfs_umount. Customers should move to accessing all CD-ROM file system formats by using the standard HP-UX commands, specifying the file system type as cdfs. For example, to mount a CD-ROM file system, use:

mount -F cdfs /dev/dsk/c0t0d4 /cdrom

There is no need to treat the cdfs file system type differently from any other file system type, therefore no special daemons or commands are required to access the variety of CD-ROM file system formats.

See mount(1M) and mount_cdfs(1M).

Bugs

If the directory on which a file system is to be mounted is a symbolic link, the file system is mounted on the directory to which the symbolic link refers, rather than being mounted on top of the symbolic link itself.

On Pioneer six disc changers (and perhaps other drives) if you mount the file system using the block device driver, the Pioneer returns information to the driver indicating there is no data, causing the mount to fail. Either mount the file system again (which will should succeed), or use the raw device driver.

AUTHOR

pfs_mount was developed by Young Minds, Inc.

FILES

/etc/mnttab

table of mounted file systems

/etc/pfs_fstab

table of PFS file systems

/etc/pfs_mtab

table of mounted PFS file systems