HPlogo HP-UX Reference > C

complex(5)

Itanium(R)-based System Only
HP-UX 11i Version 2: December 2007 Update
» 

Technical documentation

 » Table of Contents

 » Index

NAME

complex — complex functions and macros

SYNOPSIS

#include <complex.h>

DESCRIPTION

This file contains declarations of all the functions in the Complex Library (described in Section (3M)).

It defines the types

extended

The Itanium-based system 80-bit double-extended type.

quad

An IEEE 754-compliant, 128-bit floating-point type. On HP-UX, quad is a synonym for long double.

It defines the macros

complex

Expands to _Complex, a keyword designating complex types.

imaginary

Expands to _Imaginary, a keyword designating imaginary types.

These macros and the names of the real types, in combination, provide designations for the complex and imaginary types

float complex

double complex

long double complex

extended complex

quad complex

float imaginary

double imaginary

long double imaginary

extended imaginary

quad imaginary

This file also defines the macros

_Imaginary_I

Expands to a constant expression of type const float imaginary, with the value of the imaginary unit (a number whose square is -1).

_Complex_I

Expands to a constant expression of type const float complex, with the value of the imaginary unit.

I

Expands to _Imaginary_I. It can be used to efficiently construct complex expressions in the style x + y*I, where x and y are real.

This header is for Itanium-based systems only. To use it, compile with the default -Ae option. To use the types extended complex, quad complex, extended imaginary, or quad imaginary, compile with the -fpwidetypes option.

FILES

/usr/include/complex.h

STANDARDS CONFORMANCE

<complex.h> : ISO/IEC C99 (including Annex G, ``IEC 60559-compatible complex arithmetic'')