HPlogo HP-UX Reference > A

amdload(1M)

HP-UX 11i Version 2: December 2007 Update
» 

Technical documentation

 » Table of Contents

 » Index

NAME

amdload — downloads new firmware to the disk array controllers, the disk system BCC controllers, and disks

SYNOPSIS

amdload -D { all | channel:ID,channel:ID,...} codefile ArrayID

amdload -C { all | cntrlrID} codefile ArrayID

amdload -S { all | channel,channel, ...} [-force] codefile ArrayID

amdload -i ArrayID

amdload -?

Remarks

Downloading firmware should only be performed by service-trained personnel. If firmware is not downloaded properly, it may cause the disk array or some its components to become inoperative.

DESCRIPTION

amdload copies new firmware code to the disk array controllers, the disk system BCC controllers, or the disks in the disk array identified by ArrayID. The new code is stored in the file identified by codefile.

The ArrayID used to address the disk array can be the disk array serial number or name, if one has been assigned to the disk array.

Identifying Disk Modules

Disk modules are identified within Array Manager 60 using a numbered pair of the form n:n. The first number identifies the SCSI channel (or bus) connecting the array controller to the enclosure containing the disk module. The channel number is indicated on the back of the array controller enclosure. The second number is the disk module SCSI ID. The SCSI ID is determined by the slot in which the disk module is installed, but is not the same as the physical slot number (0-9).

For example, the numbered pair 2:1 identifies the disk module on channel 2 with a SCSI ID of 1. Refer to the Disk Array FC/60 User's Guide for more information on disk module addressing.

Options

amdload supports the following options:

-C

Download new firmware to the disk array controllers. The new code is stored in the file identified by codefile.

If the all option is included, download firmware to both disk array controllers.

If the cntrlrID option is included, download firmware to the specified controller (A or B).

There are three controller firmware files: bootware, firmware, and NVSRAM. The files must be downloaded in the proper sequence. When upgrading firmware, download the bootware code file first, followed by the firmware code file, and finally the NVSRAM file. When converting to an earlier version of firmware (downgrading), the correct sequence is firmware first, then bootware, followed by NVSRAM.

NOTE: On firmware version HP07 and higher, the bootware and firmware files are available in a single "packaged" file. The packaged file should be downloaded first, followed by the NVSRAM file. This order applies for both upgrades and downgrades.

Typical code filename extensions are as follows:

*.bwd

bootware

*.apd

firmware (or "appware")

*.dlp

packaged bootware and firmware

*.dl or *.dlp

NVSRAM

-D

Download new firmware to the disks. The new code is stored in the file identified by codefile.

If the all option is included, download firmware to all disks on the disk array.

If the channel:ID option is included, download firmware only to the specified disks. Disk are identified by channel (1-6) and SCSI ID (0-4, 8-12).

-i

Display the firmware revisions for all hardware components of the specified disk array.

-S

Download new firmware to the disk system BCC controllers. The new code is stored in the file identified by codefile.

If the all option is included, download firmware to all disk system BCC controllers on the disk array.

If the channel option is included, download firmware only to the specified disk systems. Disk systems are identified by channel (1-6). Firmware will be downloaded to both BCC controllers on the disk system.

If the -force option is included, non-optimal disk states will be ignored.

-?

Display expanded usage message. This option overrides all others.

SECURITY CONFIGURATION

This command is modified for all security configurations.

Security Behavior/Restrictions

Use of this command is restricted to authorized users only.

Command Authorizations

This command requires the sysadmin authorization to successfully execute.

Privileges

The command has been modified to support least privilege. The potential privileges possessed by the command and their uses include:

allowdacread

This privilege is raised to provide discretionary read access to the devices.

allowdacwrite

This privilege is raised to provide discretionary write access to the devices.

allowmacread

This privilege is raised to provide mandatory read access to the devices.

allowmacwrite

This privilege is raised to provide mandatory write access to the devices.

filesysops

This privilege is raised to allow the mknod(2) system call to succeed.

writeaudit

The command generates its own audit records and submits these directly to the system audit trail. This privilege is raised whenever the command needs to write an audit record.

EXTERNAL INFLUENCES

Environment Variables

LC_MESSAGES determines the language in which messages are displayed. The current language settings can be checked with locale(1).

RETURN VALUE

amdload returns the following values:

0

Successful completion.

1

An error in execution (I/O, subsystem, security, etc.) occurred.

2

An error in command syntax occurred: for example, an unknown command-line option was passed.

3

Timeout in communication to server. May indicate AM60Srvr is not running.

DIAGNOSTICS

The following messages can be generated by amdload:

Usage: amdload -D {all | Chan:ID,Chan:ID,...} <codefile> <ArrayID>

amdload -C { all | <cntrlrID> } codefile <ArrayID>

amdload -S { all | <Chan>,<Chan>,...} [-force] <codefile> <ArrayID>

amdload -i <ArrayID>

Extended help: amdload -?

amdload -?

  • An error in command syntax has occurred. Re-enter the command with all necessary arguments.

amdload: Arg out of range

  • One of the arguments has exceeded its maximum or minimum size, or is incorrect in form. Check the size and form of each argument.

    amdload: The <ArrayID> entered does not identify a known, supported array

  • The specified ArrayID does not exist or does not identify a device that is communicating with the system. Verify the array exists and is operational.

amdload: Firmware download has been aborted.

  • Disk <disk> does not exist in the subsystem.

  • The specified disk does not exist in the subsystem. Re-enter the list of disks, making sure all disks are physically present. A similar message will appear for channels that do not exist.

amdload: Firmware download has been aborted.

  • There is more than one type of disk mechanism among

  • the disks selected for update.

  • Any particular firmware file is only valid for one type of disk mechanism. This message will appear if the disks specified for update are of more than one mechanism type. Re-enter the list of disks, only including disks of one mechanism type.

amdload: The disk <disk> was repeated in your list.

  • Re-enter the command, listing each item once.

  • This message will appear if a disk or channel is repeated in the input list. Be sure to list each item once.

amdload: Firmware download has been aborted.

  • LUN <lun> is not in an Optimal state. Wait until all LUNs are in

  • an Optimal state before attempting further firmware downloads.

  • LUNs must be in an Optimal state before attempting disk or array controller downloads. This message will appear if any LUNs are not Optimal prior to a download, or if a LUN enters a non-Optimal state between disk downloads.

amdload: Error in command execution, <Additional Error Info>:

  • <Error Info Decode>

  • The command failed due to a device error, an internal error, or a system error. The Additional Error Info and Error Info Decode fields will hold specifics about the failure and its cause.

EXAMPLES

Download new firmware from file coderev2.1 to both disk array controllers on disk array RACK_51:

amdload -C all coderev2.1 RACK_51

Download new firmware from file diskrev3.2 to the specified disks (channel 6, SCSI ID 2 and channel 6, SCSI ID 4) in disk array RACK_51:

amdload -D 6:2,6:4 diskrev3.2 RACK_51

Download new firmware from file bccrev14 to the BCC controllers on all the disk systems on disk array RACK_51:

amdload -S all bccrev14 RACK_51

DEPENDENCIES

AM60Srvr must be running to execute this command. See AM60Srvr(1M).

AUTHOR

amdload was developed by HP.