HPlogo HP-UX Reference Volume 5 of 5 > p

pd_att_queue(5)

» 

Technical documentation

Complete book in PDF

 » Table of Contents

 » Index

NAME

pd_att_queue — list of attributes for an HPDPS queue object

DESCRIPTION

The following is a list of valid attributes and values for the queue object class of the HP Distributed Print Service.

Attributes for a Queue Object

|------------------------------------------------------------------------| | Settable Attribute Listing | Specifiable Attribute Listing | |------------------------------------|-----------------------------------| | backlog-lower-bound | There are no specifiable | | backlog-udpdate-interval | attributes for a queue object. | | backlog-upper-bound | | | descriptor | | | list-of-managers | | | message | | | notify-operator | | | notification-profile | | | protected-attributes | | | scheduler-ready | | |------------------------------------------------------------------------| |------------------------------------------------------------------------| | Table 1-1. Queue Attributes | |------------------------------------------------------------------------| | Attribute | Description | |------------|-----------------------------------------------------------| | Name | associated-server | |------------|-----------------------------------------------------------| | Type | Non Settable | |------------|-----------------------------------------------------------| | Explanation| Indicates the name of the server in which this queue | | | resides. | |------------|-----------------------------------------------------------| | Value Type | Single value. | |------------|-----------------------------------------------------------| | Values | A text string up to 255 characters that contains the name | | | of the server. Implicitly set from the argument | | | (ServerName:QueueName) specified when this queue was | | | created with the pdcreate command. | |------------|-----------------------------------------------------------| | Default | No default. | |------------|-----------------------------------------------------------| | Usage | | | Guidelines | | |------------|-----------------------------------------------------------| |------------|-----------------------------------------------------------| | Attribute | Description | |------------|-----------------------------------------------------------| | Name | backlog-lower-bound | |------------|-----------------------------------------------------------| | Type | Settable with the pdcreate and pdset commands. | |------------|-----------------------------------------------------------| | Explanation| Identifies the limit (time to print jobs within the | | | queue) below which the queue is not considered | | | backlogged. A backlogged condition is reset when the | | | queue-backlog value is less than this value, if backlog | | | computing is enabled. | |------------|-----------------------------------------------------------| | Value Type | Single value. | |------------|-----------------------------------------------------------| | Values | [HH:]MM. Unit is minutes. | |------------|-----------------------------------------------------------| | Syntax | backlog-lower-bound=[HH:]MM. | | | | | | Can be just minutes or hours and minutes. | | | | | | For example: -x "backlog-lower-bound=5" | | | or | | | -x "backlog-lower-bound=1:10" | |------------|-----------------------------------------------------------| | Default | No default. | |------------|-----------------------------------------------------------| | Usage | o The value for this attribute must be less than or | | Guidelines | equal to the value specified for the | | | backlog-upper-bound attribute. | | | o The value for the attribute backlogged is reset to | | | false when the value for the queue-backlog attribute | | | becomes less than this value if backlog computing is | | | enabled (backlog-update-interval value not equal to | | | 0). | |------------|-----------------------------------------------------------| |------------|-----------------------------------------------------------| | Attribute | Description | |------------|-----------------------------------------------------------| | Name | backlog-update-interval | |------------|-----------------------------------------------------------| | Type | Settable with the pdcreate or pdset commands. | |------------|-----------------------------------------------------------| | Explanation| Specifies how often the queue backlog is computed. | |------------|-----------------------------------------------------------| | Value Type | Single value. | |------------|-----------------------------------------------------------| | Values | [HH:]MM. Unit is minutes. | | | | | | If set to 0, backlog computing is disabled. | |------------|-----------------------------------------------------------| | Default | The greater value of the following: | | | | | | 1 minute | | | or | | | The value of the backlog-upper-bound attribute | | | divided by 30. | |------------|-----------------------------------------------------------| | Usage | o The value for this attribute must be less than or | | Guidelines | equal to the value specified for the | | | backlog-upper-bound attribute. | | | o This default value is set when the queue is created. | | | If the value for the backlog-upper-bound attribute is | | | changed later with the pdset, the value for this | | | attribute is not changed. | |------------|-----------------------------------------------------------| |------------|-----------------------------------------------------------| | Attribute | Description | |------------|-----------------------------------------------------------| | Name | backlog-upper-bound | |------------|-----------------------------------------------------------| | Type | Settable with the pdcreate or pdset commands. | |------------|-----------------------------------------------------------| | Explanation| Identifies the limit (time to print the jobs in the | | | queue) above which the queue is considered backlogged. | |------------|-----------------------------------------------------------| | Value Type | Single value. | |------------|-----------------------------------------------------------| | Values | [HH:]MM. Unit is minutes. | |------------|-----------------------------------------------------------| | Default | No default. | |------------|-----------------------------------------------------------| | Usage | o The value for this attribute must be greater than or | | Guidelines | equal to the value specified for the | | | backlog-lower-bound attribute. | | | o The value for the attribute backlogged is set to true | | | when the value for the queue-backlog attribute | | | exceeds this value if backlog computing is enabled. | |------------|-----------------------------------------------------------| |------------|-----------------------------------------------------------| | Attribute | Description | |------------|-----------------------------------------------------------| | Name | backlogged | |------------|-----------------------------------------------------------| | Type | Not Settable | |------------|-----------------------------------------------------------| | Explanation| Identifies whether the queue is backlogged. | |------------|-----------------------------------------------------------| | Value Type | Single value. | |------------|-----------------------------------------------------------| | Values | One of the following fixed values: | | | | | | Fixed Value Input Synonym | | | true yes | | | false no | |------------|-----------------------------------------------------------| | Default | false | |------------|-----------------------------------------------------------| | Usage | o This attribute value is set to true when backlog | | Guidelines | computing is enabled (backlog-update-interval not | | | equal to 0) and the queue-backlog value exceeds | | | backlog-upper-bound. | | | o This attribute value is set to false when the | | | queue-backlog value falls below the | | | backlog-lower-bound value. | |------------|-----------------------------------------------------------| |------------|-----------------------------------------------------------| | Attribute | Description | |------------|-----------------------------------------------------------| | Name | descriptor | |------------|-----------------------------------------------------------| | Type | Settable with the pdcreate or pdset commands. | |------------|-----------------------------------------------------------| | Explanation| Provides a description of this queue. | |------------|-----------------------------------------------------------| | Value Type | Single value. | |------------|-----------------------------------------------------------| | Values | A text string up to 4095 characters that describes this | | | queue. You may want to specify such things as: | | | o The name of the department or the account number for | | | the users of this queue. | | | o Any other information that is unique to your company | | | or organization. | |------------|-----------------------------------------------------------| | Default | No default | |------------|-----------------------------------------------------------| | Usage | o The use of this attribute is optional. However, a | | Guidelines | detailed description of this queue is helpful to users| | | who want to determine where to submit a given job or | | | administrators who want to determine which queue to | | | associate with a logical printer. | |------------|-----------------------------------------------------------| |------------|-----------------------------------------------------------| | Attribute | Description | |------------|-----------------------------------------------------------| | Name | list-of-managers | |------------|-----------------------------------------------------------| | Input | managers | | Synonym | | |------------|-----------------------------------------------------------| | Type | Settable with the pdcreate or pdset commands. | |------------|-----------------------------------------------------------| | Explanation| Lists the people responsible for the maintenance and | | | operation of this queue. | |------------|-----------------------------------------------------------| | Value Type | Multiple values. | |------------|-----------------------------------------------------------| | Values | A text string up to 255 characters per person that | | | contains the name or ID of the person responsible for | | | this queue. | |------------|-----------------------------------------------------------| | Default | No default. | |------------|-----------------------------------------------------------| | Usage | | | Guidelines | | |------------|-----------------------------------------------------------| |------------|-----------------------------------------------------------| | Attribute | Description | |------------|-----------------------------------------------------------| | Name | logical-printers-assigned | |------------|-----------------------------------------------------------| | Type | Non Settable. | |------------|-----------------------------------------------------------| | Explanation| Lists the logical printers associated with this queue. | |------------|-----------------------------------------------------------| | Value Type | Multiple values. | |------------|-----------------------------------------------------------| | Values | A text string up to 255 characters per printer that | | | contains the logical printer global ID. Implicitly set | | | to the logical printer attribute associated-queue value | | | when the logical printer is created. | |------------|-----------------------------------------------------------| |------------|-----------------------------------------------------------| | Default | No default. | |------------|-----------------------------------------------------------| | Usage | | | Guidelines | | |------------|-----------------------------------------------------------| |------------|-----------------------------------------------------------| | Attribute | Description | |------------|-----------------------------------------------------------| | Name | logical-printers-ready | |------------|-----------------------------------------------------------| | Type | Non Settable. | |------------|-----------------------------------------------------------| | Explanation| Lists the enabled logical printers that are associated | | | with this queue. | |------------|-----------------------------------------------------------| | Value Type | Multiple values. | |------------|-----------------------------------------------------------| | Values | A text string up to 255 characters that contains the ID | | | of the physical printers (per printer) that are ready to | | | accept jobs. Implicitly set when physical printers are | | | enabled and have a state of either idle, | | | connecting-to-printer, or printing. Implicitly reset | | | when a physical printer is disabled, paused, timed-out, | | | needs-attention, or needs-key-operator-attention. | |------------|-----------------------------------------------------------| | Default | No default. | |------------|-----------------------------------------------------------| | Usage | o The list changes as logical printers are enabled or | | Guidelines | disabled. | |------------|-----------------------------------------------------------| |------------|-----------------------------------------------------------| | Attribute | Description | |------------|-----------------------------------------------------------| | Name | message | |------------|-----------------------------------------------------------| | Type | Settable with the pdcreate or pdset commands. | |------------|-----------------------------------------------------------| | Explanation| Provides a message associated with this queue. | |------------|-----------------------------------------------------------| | Value Type | Single value. | |------------|-----------------------------------------------------------| | Values | A text string up to 4095 characters that contains | | | information about this queue. | |------------|-----------------------------------------------------------| | Default | No default. | |------------|-----------------------------------------------------------| | Usage | | | Guidelines | | |------------|-----------------------------------------------------------| |------------|-----------------------------------------------------------| | Attribute | Description | |------------|-----------------------------------------------------------| | Name | notification-profile | |------------|-----------------------------------------------------------| | Type | Settable with the pdcreate or pdset commands. | |------------|-----------------------------------------------------------| | Explanation| Designates which persons are to be notified of specific | | | events related to this queue, and how they are to be | | | notified. | |------------|-----------------------------------------------------------| | Value Type | Multiple Values | |------------|-----------------------------------------------------------| | Values | This is a complex attribute, which has the following | | | components: | | | | | | o event-identifiers | | | o delivery-method | | | o event-comment | | | o delivery-address | | | o locale | |------------|-----------------------------------------------------------| | Syntax | -x "notification-profile={event-identifiers=events | | | delivery-method=value event-comment='text' | | | deliver-address=value locale=value}" | | | | | | For example: | | | | | | -x "notification-profile={event-identifiers=class-error | | | delivery-method=electronic-mail | | | event-comment='fix problem' delivery-address=mary@travel | | | locale=C}" | |------------|-----------------------------------------------------------| | Component | Description | |------------|-----------------------------------------------------------| | event- | Explanation: Specifies the events for which the | | identifiers| person is to receive messages. | | | Value Type: Multiple values. | | | Values: Any of the event values listed for spooler | | | attribute events-supported in pd_att_spooler. | | | Default: | | | o object-deleted | | | o object-cleaned | | | o queue-backlogged | |------------|-----------------------------------------------------------| | delivery- | Explanation: Specifies how the user is to receive the | | method | event messages. | | | Value Type: Single value. | | | Values: One of the following fixed values: | | | Fixed Value Input Synonym | | | electronic-mail e-mail, email | | | file | | | file-add-to | | | message | | | none | | | Default: electronic-mail | |------------|-----------------------------------------------------------| | event- | Explanation: Supplies textual information that is | | comment | appended to the message | | | Value Type: Single value. | | | Values: A text string up to 4095 characters that | | | supplies additional information concerning the event. | | | Default: No value. | |------------|-----------------------------------------------------------| | delivery- | Explanation: The address of the person that is to | | address | receive the event messages. | | | Value Type: Single value. | | | Values: A text string that contains the name and node | | | of the person that is to receive notification. | | | Default: The login of the person that created the | | | queue with the pdcreate command. | |------------|-----------------------------------------------------------| | locale | Explanation: Identifies the locale that the messages are | | | to be sent in. | | | Value Type: Single value. | | | Values: A text string that identifies the locale to | | | be used. This is used to determine the language and | | | coded character set that the information is to be | | | sent in. | | | Default: The locale of the person that created this | | | queue with the pdcreate command. | |------------|-----------------------------------------------------------| |------------|-----------------------------------------------------------| | Attribute | Description | |------------|-----------------------------------------------------------| | Name | notify-operator | |------------|-----------------------------------------------------------| | Input | operators | | Synonym | | |------------|-----------------------------------------------------------| | Type | Settable with the pdcreate or pdset commands. | |------------|-----------------------------------------------------------| | Explanation| Identifies people that are to receive the attribute | | | job-message-to-operator message. | |------------|-----------------------------------------------------------| | Value Type | Multiple values. | |------------|-----------------------------------------------------------| | Values | This is a complex attribute with the following | | | components: | | | o delivery-method | | | o delivery-address | |------------|-----------------------------------------------------------| | Syntax | -x "notify-operator=delivery-method value: | | | delivery-address value" | | | | | | For example: -x "notify-operator=message:op3@fastpr" | |------------|-----------------------------------------------------------| | Component | Description | |------------|-----------------------------------------------------------| | delivery- | Explanation: Specifies how the person is to receive | | method | the messages. | | | Value Type: Single Value | | | Values: One of the following fixed values: | | | electronic-mail | | | message | | | none | | | Default: electronic-mail | |------------|-----------------------------------------------------------| | delivery- | Explanation: The address of the person that is to | | address | receive the message. | | | Value Type: Single Value | | | Values: A text string that contains the user ID and | | | node of the person that is to receive the message. | | | Default: The login of the person that created this | | | queue. | |------------|-----------------------------------------------------------| |------------|-----------------------------------------------------------| | Attribute | Description | |------------|-----------------------------------------------------------| | Name | object-class | |------------|-----------------------------------------------------------| | Type | Non Settable | |------------|-----------------------------------------------------------| | Explanation| Identifies the object class to which this object belongs. | |------------|-----------------------------------------------------------| | Value Type | Single value. | |------------|-----------------------------------------------------------| | Values | The value of this attribute is queue | |------------|-----------------------------------------------------------| | Default | queue | |------------|-----------------------------------------------------------| | Usage | | | Guidelines | | |------------|-----------------------------------------------------------| |------------|-----------------------------------------------------------| | Attribute | Description | |------------|-----------------------------------------------------------| | Name | physical-printers-assigned | |------------|-----------------------------------------------------------| | Type | Non Settable | |------------|-----------------------------------------------------------| | Explanation| Lists the physical printers that receive jobs from this | | | queue. | |------------|-----------------------------------------------------------| | Value Type | Multiple values. | |------------|-----------------------------------------------------------| | Values | A text string up to 255 characters per printer that | | | contains the ID of a physical printer that is associated | | | with this queue. Implicitly set when a physical printer | | | registers and its associated-queue attribute value is the | | | name of this queue. | |------------|-----------------------------------------------------------| | Default | No default. | |------------|-----------------------------------------------------------| | Usage | | | Guidelines | | |------------|-----------------------------------------------------------| |------------|-----------------------------------------------------------| | Attribute | Description | |------------|-----------------------------------------------------------| | Name | physical-printers-ready | |------------|-----------------------------------------------------------| | Type | Non Settable | |------------|-----------------------------------------------------------| | Explanation| Lists the enabled physical printers that can receive a | | | job from this queue. | |------------|-----------------------------------------------------------| | Value Type | Multiple values. | |------------|-----------------------------------------------------------| | Values | A text string up to 255 characters per printer that | | | contains the global ID of a physical printer assigned to | | | this queue that is ready. | |------------|-----------------------------------------------------------| | Default | No default. | |------------|-----------------------------------------------------------| | Usage | o A physical printer becomes ready when it is enabled | | Guidelines | and the state is either idle, connecting-to-printer, | | | or printing. | |------------|-----------------------------------------------------------| |------------|-----------------------------------------------------------| | Attribute | Description | |------------|-----------------------------------------------------------| | Name | protected-attributes | |------------|-----------------------------------------------------------| | Type | Settable with the pdcreate or pdset commands. | |------------|-----------------------------------------------------------| | Explanation| Specifies one or more queue attributes that you do not | | | want HPDPS operators to set or change. | |------------|-----------------------------------------------------------| | Value Type | Multiple values. | |------------|-----------------------------------------------------------| | Values | One or more queue attribute names. | |------------|-----------------------------------------------------------| | Default | protected-attributes | |------------|-----------------------------------------------------------| | Usage | o Normally, anyone with DCE write permission for queues | | Guidelines | can set values for queue attributes. By default, the | | | pd_admin and pd_operator DCE groups both have write | | | permission. Once you define a queue attribute as a | | | protected attribute, DCE delete permission is required| | | to modify the attribute. Members of the pd_operator | | | DCE group do not have delete permission unless | | | modifications have been made to the default | | | permissions for that group. | |------------|-----------------------------------------------------------| |------------|-----------------------------------------------------------| | Attribute | Description | |------------|-----------------------------------------------------------| | Name | queue-backlog | |------------|-----------------------------------------------------------| | Input | backlog, current-backlog | | Synonym | | |------------|-----------------------------------------------------------| | Type | Non Settable | |------------|-----------------------------------------------------------| | Explanation| Specifies the amount of time that this queue might be | | | backlogged. This is a computed estimate of time it will | | | take to print all of the jobs currently in the queue. | |------------|-----------------------------------------------------------| | Value Type | Single value. | |------------|-----------------------------------------------------------| | Values | [HH:]MM. Unit is minutes. | |------------|-----------------------------------------------------------| | Default | No default. | |------------|-----------------------------------------------------------| | Usage | | | Guidelines | | |------------|-----------------------------------------------------------| |------------|-----------------------------------------------------------| | Attribute | Description | |------------|-----------------------------------------------------------| | Name | queue-name | |------------|-----------------------------------------------------------| | Type | Non Settable | |------------|-----------------------------------------------------------| | Explanation| Uniquely identifies this queue object. | |------------|-----------------------------------------------------------| | Value Type | Single value. | |------------|-----------------------------------------------------------| | Values | A text string up to 255 characters that contains the name | | | of this queue. Set by the argument | | | (ServerName:QueueName) of the pdcreate command when this | | | queue was created. | |------------|-----------------------------------------------------------| | Default | No default. | |------------|-----------------------------------------------------------| | Usage | o Name of this queue must be unique within the DCE | | Guidelines | cell. | |------------|-----------------------------------------------------------| |------------|-----------------------------------------------------------| | Attribute | Description | |------------|-----------------------------------------------------------| | Name | queue-state | |------------|-----------------------------------------------------------| | Type | Non Settable | |------------|-----------------------------------------------------------| | Explanation| Identifies the current state of the queue. | |------------|-----------------------------------------------------------| | Value Type | Single value. | |------------|-----------------------------------------------------------| | Values | One of the following fixed values: | | | | | | paused | | | ready | |------------|-----------------------------------------------------------| | Default | No default. | |------------|-----------------------------------------------------------| | Usage | | | Guidelines | | |------------|-----------------------------------------------------------| |------------|-----------------------------------------------------------| | Attribute | Description | |------------|-----------------------------------------------------------| | Name | scheduler-ready | |------------|-----------------------------------------------------------| | Input | scheduler | | Synonym | | |------------|-----------------------------------------------------------| | Type | Settable with the pdcreate or pdset commands. | |------------|-----------------------------------------------------------| | Explanation| Identifies the scheduling method used to determine the | | | order in which jobs in the queue are sent to physical | | | printers. | |------------|-----------------------------------------------------------| | Value Type | Single Value | |------------|-----------------------------------------------------------| | Values | One of the following fixed values: | | | | | | fifo | | | priority-fifo | | | | | | Must be one of the spooler attribute schedulers-supported | | | values. | |------------|-----------------------------------------------------------| | Default | priority-fifo | |------------|-----------------------------------------------------------| | Usage | o This attribute can be changed even if there are jobs | | Guidelines | currently in the queue. The jobs currently in the | | | queue will be reordered according to the new | | | scheduler. | |------------|-----------------------------------------------------------|

© Hewlett-Packard Development Company, L.P.