HPlogo HP-UX Reference Volume 5 of 5 > n

ndir(5)

» 

Technical documentation

Complete book in PDF

 » Table of Contents

 » Index

NAME

ndir.h — format of HP-UX directory streams

SYNOPSIS

#include <ndir.h>

DESCRIPTION

This header file defines data types used by the directory stream routines described in directory(3C). It is provided to allow older HP-UX programs to compile unmodified. This file is obsoleted starting from HP-UX 10.30 and is going to be removed in future releases. The header file <dirent.h> described on dirent(5) should be used in all new programs for compatibility with System V Release 3, the X/Open Portability Guide, and the IEEE P1003.1 POSIX standard.

The following data types are defined:

DIR

A structure containing information about an open directory stream.

struct direct

A structure defining the format of entries returned by the old HP-UX readdir function (see directory(3C)).

The struct direct structure includes the following members:

char d_name[MAXNAMLEN+1]; /* name of directory entry */ long d_ino; /* file serial number */ short d_namlen; /* length of string in d_name */ short d_reclen; /* length of this record */

The constant MAXNAMLEN is defined in <ndir.h>.

This file also contains external declarations for the functions in the directory(3C) package, including the following declaration:

extern struct direct *readdir();

WARNINGS

lint(1) might complain about programs that include this file, although they compile and run correctly.

AUTHOR

ndir.h was developed by the University of California, Berkeley, and HP.

© Hewlett-Packard Development Company, L.P.