HPlogo HP-UX Reference Volume 5 of 5 > m

math(5)

» 

Technical documentation

Complete book in PDF

 » Table of Contents

 » Index

NAME

math — math functions and constants

SYNOPSIS

#include <math.h>

DESCRIPTION

This file contains declarations of all the functions in the Math Library (described in Section (3M)).

It also defines the following constants that may be used in initializations or returned as error values:

HUGE_VAL

The maximum value (type double) of a double-precision floating-point number (IEEE positive INFINITY).

NAN

A quiet NaN (Not-a-Number) value (type float).

INFINITY

A positive infinity value (type float).

The following mathematical constants are defined for user convenience:

M_E

The base of natural logarithms (e).

M_LOG2E

The base-2 logarithm of e.

M_LOG10E

The base-10 logarithm of e.

M_LN2

The natural logarithm of 2.

M_LN10

The natural logarithm of 10.

M_PI

The ratio of the circumference of a circle to its diameter. (There are also several fractions of π, its reciprocal, and its square root: M_PI_2, M_PI_4, M_1_PI, M_2_PI, and M_2_SQRTPI).

M_SQRT2

The positive square root of 2.

M_SQRT1_2

The positive square root of 1/2.

For the definitions of various machine-dependent constants, see the description of the <values.h> header file.

FILES

/usr/include/math.h

STANDARDS CONFORMANCE

<math.h>: SVID3, XPG4.2, ANSI C

© Hewlett-Packard Development Company, L.P.