HPlogo HP-UX Reference Volume 2 of 5 > m

mount_vxfs(1M)

» 

Technical documentation

Complete book in PDF

 » Table of Contents

 » Index

NAME

mount, umount (vxfs) — mount and unmount a VxFS file system

SYNOPSIS

/usr/sbin/mount [-l] [-v|-p]

/usr/sbin/mount [-F vxfs] [-eQ] -a

/usr/sbin/mount [-F vxfs] [-eQrV] [-o specific_options] {special|mount_point}

/usr/sbin/mount [-F vxfs] [-eQrV] [-o specific_options] special mount_point

/usr/sbin/umount [-V] [-v] {special | directory}

/usr/sbin/umount [-F vxfs] [-v] -a

DESCRIPTION

The mount command attaches special, a removable file system, to directory, a directory on the file tree. directory, which must already exist, will become the name of the root of the newly mounted file system. mount can be invoked on any removable file system, except /. If mount is invoked with no arguments it lists all the mounted file systems from the mounted file system table, /etc/mnttab. special and directory must be given as absolute path names.

The umount command unmounts mounted file systems.

Only the superuser can mount and umount file systems. Other users can use mount to list mounted file systems.

Options

mount recognizes the following options:

-a

Attempt to mount all file systems described in /etc/fstab. All optional fields in /etc/fstab must be included and supported. If -F vxfs is specified, all VxFS file systems in /etc/fstab are mounted. If noauto is specified in an entry's option list, this entry is skipped. File systems are not necessarily mounted in the order listed in /etc/fstab.

-e

Verbose mode. Write a message to the standard output indicating which file system is being mounted.

-F vxfs

Specifies the file system type (vxfs).

-l

Limit actions to local file systems only.

-o specific_options

Specifies options specific to the VxFS file system type. specific_options is a list of comma separated suboptions and/or keyword/attribute pairs intended for the VxFS-specific module of the command.

The following specific_options are valid on a VxFS file system:

rw

Read-write (default).

ro

Read-only.

suid

Set-user-ID execution allowed (default).

nosuid

Set-user-ID execution not allowed.

quota

Disk quotas enabled (valid only for rw type file systems). VxFS maintains quota information in a private area of the file system. If the file system is mounted with quotas enabled, and the file system was previously mounted with quotas disabled and was modified, then the quota information is rebuilt. This may take awhile.

remount

Changes the mount options for a mounted file system, such as logging and caching policies or whether the file system can be written to.

log|delaylog|tmplog|nolog

Controls intent logging. File system integrity across system failure requires that logging be enabled. The default is log. In log mode, file system structural changes are logged to disk before the system call returns to the application. If the system crashes, fsck_vxfs(1M) will complete logged operations that have not completed.

In delaylog mode, some system calls return before the intent log is written. This improves the performance of the system, but some changes are not guaranteed until a short time later when the intent log is written. This mode approximates traditional UNIX system guarantees for correctness in case of system failures.

In tmplog mode, the intent log is almost always delayed. This improves performance, but recent changes may disappear if the system crashes. This mode is only recommended for temporary file systems.

In nolog mode, the intent log is disabled. The other three logging modes provide fast file system recovery; nolog does not provide fast file system recovery. With nolog mode, a full structural check must be performed after a crash; this may result in loss of substantial portions of the file system, depending upon activity at the time of the crash. Usually, a nolog file system should be rebuilt with mkfs_vxfs(1M) after a crash. The nolog mode should only be used for memory resident or very temporary file systems.

blkclear

Ensure that all data extents are cleared before being allocated to a file (requires synchronous zeroing, on disk, of certain newly allocated extents). This prevents uninitialized data from appearing in a file being written at the time of a system crash.

snapof=filesystem

Mount the file system as a snapshot of filesystem, where filesystem is either the directory on which a VxFS file system is mounted, or is the block special file containing a mounted VxFS file system. An explicit -F vxfs option is required to mount a snapshot file system.

snapsize=blocks

Used in conjunction with snapof. blocks is the size in sectors of the snapshot file system being mounted. This option is required only when the device driver is incapable of determining the size of special, and will default to the entire device if not specified.

mincache=direct|dsync|closesync|tmpcache

This option is used to alter the caching behavior of the file system.

The direct value causes any writes without the O_SYNC flag and all reads to be handled as if the VX_DIRECT caching advisory was set instead.

The dsync value causes any writes without either the O_SYNC flag or the VX_DIRECT caching advisory to be handled as if the VX_DSYNC caching advisory has been set.

The closesync, dsync and direct values all cause the equivalent of an fsync(2) to be run when the file is closed. See vxfsio(7) for an explanation of VX_DIRECT and VX_DSYNC.

The tmpcache value disables delayed extending writes, trading off integrity for performance. When this option is chosen, VxFS does not zero out new extents allocated as files are sequentially written. Uninitialized data may appear in files being written at the time of a system crash.

convosync=direct|dsync|closesync|delay

This option is used to alter the caching behavior of the file system for O_SYNC I/O operations.

The direct value causes any reads or writes with the O_SYNC flag to be handled as if the VX_DIRECT caching advisory was set instead.

The dsync value causes any writes with the O_SYNC flag to be handled as if the VX_DSYNC caching advisory was set instead.

The closesync value causes O_SYNC writes to be delayed rather than to take effect immediately. The closesync, dsync, and direct values all cause the equivalent of an fsync(2) to be run when any file is accessed with the O_SYNC flag is closed.

The delay value causes O_SYNC writes to be delayed rather than to take effect immediately. Choosing this option causes VxFS to change all O_SYNC writes into delayed writes. No special action is performed when closing a file. This option effectively cancels any data integrity guarantees normally provided by opening a file with O_SYNC.

datainlog|nodatainlog

Normally, the VxFS file system performs small O_SYNC write requests and NFS write requests by logging both the data and the time change to the inode (datainlog). If the nodatainlog option is used, the logging of synchronous write data is disabled; such writes will write the data into the file and update the inode synchronously before returning to the user.

largefiles|nolargefiles

If one of these options is specified, the file system mount will fail if the largefile compatibility bit for the file system does not match the option specified. If nolargefiles is specified and the mount succeeds, then the file system does not contain any files whose size is 2 gigabytes or larger, and such files cannot be created. If largefiles is specified and the mount succeeds, then the file system may contain files whose size is 2 gigabytes or larger, and large files can be created. The default is to mount the file system according to the largefile compatibility bit (see fsadm_vxfs(1M) and mkfs_vxfs(1M).)

-p

Report the list of mounted file systems in the /etc/fstab format.

-Q

Prevent display of error messages, resulting from an attempt to mount already mounted file systems.

-r

Mount the specified file system as read-only. Physically write-protected file systems must be mounted in this way or errors occur when access times are updated, whether or not any explicit write is attempted.

-v

Reports the regular output with file system type and flags, however, directory and special fields are reversed.

-V

Echoes the completed command line, but performs no other action. The command line is generated by incorporating the user-specified options and other information derived from /etc/fstab. This option allows the user to verify the command line.

umount recognizes the following options:

-a

Attempt to unmount all file systems described in /etc/mnttab. All optional fields in /etc/mnttab must be included and supported. If -F vxfs is specified, all VxFS file systems in /etc/mnttab are unmounted. File systems are not necessarily unmounted in the order listed in /etc/mnttab.

-F vxfs

Specifies the file system type (vxfs).

-v

Verbose mode. Write a message to the standard output indicating which file system is being unmounted.

-V

Echoes the completed command line, but performs no other action. The command line is generated by incorporating the user-specified options and other information derived from /etc/fstab. This option allows the user to verify the command line.

EXAMPLES

List the file systems currently mounted:

mount

Mount a VxFS file system /dev/dsk/c1t2d0 at directory /home

mount -F vxfs /dev/dsk/c1t2d0 /home

Unmount the same file system:

umount /dev/dsk/c1t2d0

FILES

/etc/fstab

Static information about the file systems

/etc/mnttab

Mounted file system table

STANDARDS CONFORMANCE

mount: SVID3

umount: SVID3

© Hewlett-Packard Development Company, L.P.