HPlogo HP-UX Reference Volume 2 of 5 > m

mkboot(1M)

» 

Technical documentation

Complete book in PDF

 » Table of Contents

 » Index

NAME

mkboot, rmboot — install, update or remove boot programs from disk

SYNOPSIS

/usr/sbin/mkboot [-b boot_file_path] [-c [-u] | -f | -h | -u] [-i included_lif_file] [-p preserved_lif_file] [-l | -H | -W] [-v] device

/usr/sbin/mkboot [-a auto_file_string] [-v] device

/usr/sbin/rmboot device

DESCRIPTION

mkboot is used to install or update boot programs on the specified device file.

The position on device at which boot programs are installed depends on the disk layout of the device. mkboot examines device to discover the current layout and uses this as the default. If the disk is uninitialized, the default is LVM layout. The default can be overriden by the -l, -H or -W options.

Boot programs are stored in the boot area in Logical Interchange Format (LIF), which is similar to a file system. For a device to be bootable, the LIF volume on that device must contain at least the ISL (the initial system loader) and HPUX (the HP-UX bootstrap utility) LIF files. If, in addition, the device is an LVM physical volume, the LABEL file must be present (see lvlnboot(1M) ).

Options

mkboot recognizes the following options:

-a auto_file_string

If the -a option is specified, mkboot creates an autoexecute file AUTO on device, if none exists. mkboot deposits auto_file_string in that file. If this string contains spaces, it must be quoted so that it is a single parameter.

-b boot_file_path

If this option is given, boot programs in the pathname specified by boot_file_path are installed on the given device.

-c

If this option is specified, mkboot checks if the available space on device is sufficient for the boot programs. If the -i option is also specified, mkboot checks if each included_lif_file is present in the boot programs. If the -p option is specified, it checks if each preserved_lif_file is present on the device. If all these checks succeed, mkboot exits with a status code of 0. If any of these checks fail, mkboot exits with a status code of 1. If the verbose option is also selected, a message is also displayed on the standard output.

-f

This option forces the information contained in the boot programs to be placed on the specified device without regard to the current swapping status. Its intended use is to allow the boot area to grow without having to boot the system twice (see -h option).

This option should only be used when the system is in the single user state.

This could be a dangerous operation because swap space that is already allocated and possibly in use will be overwritten by the new boot program information. A message is also displayed to the standard output stating that the operator should immediately reboot the system to avoid system corruption and to reflect new information on the running system.

A safer method for reapportioning space is to use the -h option.

This option is valid only if device has the Whole Disk layout.

-h

Specifying this option shrinks the available space allocated to swap in the LIF header by the amount required to allow the installation of the new boot programs specified by boot_file_path.

After the LIF header has been modified, reboot the system to reflect the new swap space on the running system. At this point, the new boot programs can be installed and the system rebooted again to reflect the new boot programs on the running system. This is the safe method for accomplishing the capability of the -f option.

This option is valid only if device has the Whole Disk layout.

-H

If this option is specified, mkboot treats device to be a Hard Partition layout disk. This option cannot be used along with the -l and -W options.

-i included_lif_file

If the -i option is specified one or more times, mkboot copies each included_lif_file and ignores any other LIF files in the boot programs. The sole exceptions to this rule are the files ISL and HPUX, which are copied without regard to the -i options. If included_lif_file is also specified with the -p option, the -i option is ignored. If the -i option is used with LABEL as its argument and the file LABEL does not exist in the boot programs, and device is an LVM layout disk or the -l option is used, mkboot creates a minimal LABEL file on device which will permit the system to boot on device, possibly without swap or dump.

-l

If this option is used, mkboot treats device as an LVM layout disk, regardless of whether or not it is currently set up as one. This option cannot be used along with the -H and -W options.

-p preserved_lif_file

If the -p option is specified one or more times, mkboot keeps each specified preserved_lif_file intact on device. If preserved_lif_file also appears as an argument to the -i option, that -i option is ignored. This option is typically used with the autoexecute file AUTO and with the LVM and SwitchOver/UX file LABEL.

If LABEL is specified as an argument to the -p option and LABEL does not exist on the device, and if the layout is LVM, mkboot creates a minimal LABEL file. In general, if preserved_lif_file is not on the device, mkboot fails. An exception to this condition is if the preserved_lif_file is LABEL and the layout is not LVM, in which case the LABEL file is ignored.

-u

If -u is specified, mkboot uses the information contained in the LIF header to identify the location of the swap area, boot area, and raw I/O so that installation of the boot programs does not violate any user data.

Normally, the LIF header information is overwritten on each invocation of mkboot. This option is typically used with the -W option, to modify boot programs on a disk that is actively supporting swap and/or raw I/O.

-v

If this option is specified, mkboot displays its actions, including the amount of swap space available on the specified device.

-W

If this option is specified, mkboot treats device as a disk having the Whole Disk layout. This option cannot be used along with the -l and -H options.

device

Install the boot programs on the given device special file. The specified device can identify either a character-special or block-special device. However, mkboot requires that both the block and character device special files be present. mkboot attempts to determine whether device is character or block special by examining the specified path name. For this reason, the complete path name must be supplied. If mkboot is unable to determine the corresponding device file, a message is written to the display, and mkboot exits.

rmboot removes the boot programs from the boot area.

EXAMPLES

Install default boot programs on the specified disk, treating it as an LVM disk:

mkboot -l /dev/dsk/c0t5d0

Use the existing layout, and install only SYSLIB and ODE files and preserve the EST file on the disk:

mkboot -i SYSLIB -i ODE -p EST /dev/rdsk/c0t5d0

Install only the SYSLIB file and retain the ODE file on the disk. Use the Whole Disk layout. Use the file /tmp/bootlf to get the boot programs rather than the default. (The -i ODE option will be ignored):

mkboot -b /tmp/bootlf -i SYSLIB -i ODE -p ODE -W /dev/rdsk/c0t5d0

WARNINGS

If device has a Whole Disk layout, a file system must reside on the device being modified.

When executing from a recovery system, the mkboot command (if used) must be invoked with the -f option; otherwise it will not be able to replace the boot area on your disk.

If device is, or is intended to become an LVM physical volume, device must specify the whole disk.

If device is, or is intended to become a Hard Partitioned disk, device must specify section 6.

DEPENDENCIES

mkboot and rmboot fail if file system type on device is not HFS.

LVM and Hard Partition Layouts

The -f, -h and -u options are not supported.

AUTHOR

mkboot and rmboot were developed by HP.

FILES

/usr/lib/uxbootlf

file containing default boot programs

ISL

initial system loader

HPUX

HP-UX bootstrap and installation utility

AUTO

defines default/automatic boot behavior (see hpux(1M))

LABEL

used by SwitchOver/UX and LVM

RDB

diagnostics tool

IOMAP

diagnostics tool

© Hewlett-Packard Development Company, L.P.