HPlogo HP-UX Reference Volume 2 of 5 > l

lvchange(1M)

» 

Technical documentation

Complete book in PDF

 » Table of Contents

 » Index

NAME

lvchange — change LVM logical volume characteristics

SYNOPSIS

/usr/sbin/lvchange [-a availability] [-A autobackup] [-c mirror_consistency] [-C contiguous] [-d schedule] [-D distributed] [-M mirror_write_cache] [-p permission] [-r relocate] [-s strict] [-t IO_timeout] lv_path

Remarks

Mirrored disk operations require the installation of the optional HP MirrorDisk/UX software, which is not included in the standard HP-UX operating system.

lvchange cannot be performed if the volume group is activated in shared mode.

DESCRIPTION

The lvchange command changes certain characteristics of a logical volume. Other characteristics can be changed with the lvextend and lvreduce commands (see lvextend(1M) and lvreduce(1M)).

The command-line options specify the type and extent of change. Each current characteristic for a logical volume remains in effect until explicitly changed by the corresponding option. All options take effect immediately, except -s, which takes effect only when new extents are allocated by the lvextend command.

If a logical volume is striped, its scheduling policy is always parallel and its allocation policy is always strict and noncontiguous; these attributes cannot be changed with lvchange.

The lvchange command can also be used to change the timeout value for a logical volume. This can be useful to control how long an IO request will be retried (for a transient error, like a device timeout), before giving up and declaring a pending IO to be failed. The default behavior is for the system to continue to retry an IO for a transient error until the IO can complete. Thus, the IO will not be returned to the caller until the IO can complete. By setting a non-zero IO timeout value, this will set the maximum length of time that the system will retry an IO. If the IO cannot complete before the length of time specified by the IO timeout, then the IO will be returned to the caller with an error. The actual duration of the IO request may exceed the logical volume's maximum IO timeout value when the underlying physical volume(s) have timeouts which either exceed the logical volume's timeout value or are not an integer multiple of the logical volume's timeout value (see pvchange(1M) for details on how to change the IO timeout value on a physical volume).

Options and Arguments

The -c, -d, -M, and -s options are meaningful only if the optional HP MirrorDisk/UX software has been installed on the system.

lvchange recognizes the following options and arguments:

lv_path

The block device path name of a logical volume.

-a availability

Set logical volume availability. availability can have one of the following values:

y

Make a logical volume available. An open of the logical volume will succeed.

n

Make a logical volume temporarily unavailable. An open of the logical volume will fail. However, all current processes that have the logical volume open remain open.

-A autobackup

Set automatic backup for this invocation of this command. autobackup can have one of the following values:

y

Automatically back up configuration changes made to the logical volume. This is the default.

After this command executes, the vgcfgbackup command (see vgcfgbackup(1M)) is executed for the volume group to which the logical volume belongs.

n

Do not back up configuration changes this time.

-c mirror_consistency

Set mirror consistency recovery. This option is effective only when -M n is specified or previously set. mirror_consistency can have one of the following values:

y

Set mirror consistency recovery on. LVM achieves mirror consistency during volume group activation by going through all logical extents and copying data from a nonstale copy to the other mirror copies.

n

Set mirror consistency recovery off. LVM does not perform mirror consistency recovery on this logical volume when the volume group is activated.

-C contiguous

Set the contiguous allocation policy. contiguous can have one of the following values:

y

Set a contiguous allocation policy. Physical extents are allocated in ascending order without any gap between adjacent extents and all extents are contained in a single physical volume.

n

Do not set a contiguous allocation policy.

A nonempty logical volume that has a noncontiguous allocation policy cannot be changed to a contiguous allocation policy unless it happens to meet all the requirements of the contiguous allocation policy. See lvcreate(1M) for more information about the contiguous allocation policy.

-d schedule

Set the scheduling policy when a logical extent with more than one mirror is written. (The scheduling policy of a striped logical volume is striped and cannot be changed.) schedule can have one of the following values:

p

Establish a parallel scheduling policy.

s

Establish a sequential scheduling policy. Use this value with care, because it leads to performance loss in most cases.

-D distributed

Change the distributed allocation policy. distributed can have one of the following values:

y

Turn on distributed allocation.

n

Turn off distributed allocation.

f

Force distributed allocation to be on.

When the distributed allocation policy is turned on, only one free extent is allocated from the first available physical volume. The next free extent is allocated from the next available physical volume. Allocation of free extents proceeds in round-robin order on the list of available physical volumes.

When the distributed allocation policy is turned off, all available free extents are allocated from each available physical volume before proceeding to the next available physical volume.

The distributed allocation policy REQUIRES the PVG-strict allocation policy ( -s g ) to ensure that mirrors of distributed extents do not overlap (for maximum availability).

The distributed allocation policy is incompatible with the striped scheduling policy ( -i stripes ) and the contiguous allocation policy ( -C y ).

See lvcreate(1M) for more information on the distributed allocation policy.

The -D y option will fail if the existing logical volume has any two consecutive logical extents on the same physical volume. To override this failure, use the -D f option.

If a logical volume with the distributed allocation policy has at least two consecutive logical extents on the same physical volume, then lvdisplay(1M) will display the allocation as partially-distributed (vs. distributed).

See lvdisplay(1M) for display values.

-M mirror_write_cache

Set the Mirror Write Cache flag. This option is allowed only when the logical volume is not opened. mirror_write_cache can have one of the following values:

y

Set Mirror Write Cache on. Every write to a mirror copy is recorded in the Mirror Write Cache and written into the Mirror Consistency Record on the disk if a cache-miss occurs. This allows LVM to determine whether all mirror copies are identical, even across system crashes. When the volume group is activated, the Mirror Consistency Record is used to perform mirror consistency recovery.

n

Set Mirror Write Cache off. Mirror write does not incur an additional write to the Mirror Consistency Record on the disk.

-p permission

Set the access permission. permission can have one of the following values:

w

Set the access permission to read-write.

r

Set the access permission to read-only.

-r relocate

Set the bad block relocation policy. relocate can have one of the following values:

y

Allow bad block relocation. Upon a media failure (detection of a bad block of data on disk), LVM will mark the failed block in the Bad Block Directory, and attempt to relocate the block to a new location on disk. If relocation is successful then no error will be returned, and future I/O requests which contain the bad block will be directed to the new location. If relocation is unsuccessful, an I/O error will be returned, and subsequent I/O requests containing the bad block will again attempt relocation.

n

Prevent bad block relocation. Upon a media failure, LVM will mark the failed block as bad in the Bad Block Directory, but will NOT attempt to relocate the bad block to a new location on disk. Future I/O requests which contain the bad block will return with an I/O error. No attempt will be made to access the bad block.

N

Disable bad block relocation and the Bad Block Directory. Upon a media failure, LVM will NOT attempt to relocate the bad block. In addition it will NOT enter the block in the Bad Block Directory. LVM will have no record of the block being bad, and will attempt to access it on future I/O requests.

-s strict

Set the strict allocation policy. Mirror copies of a logical extent can be allocated to share or not share the same physical volume or physical volume group. This option only makes sense when the physical volumes of the volume group that owns the specified logical volume reside on different physical disks. strict can have one of the following values:

y

Set a strict allocation policy. Mirrors of a logical extent cannot share the same physical volume.

g

Set a PVG-strict allocation policy. Mirrors of a logical extent cannot share the same physical volume group.

n

Do not set a strict or a PVG-strict allocation policy. Mirrors of a logical extent can share the same physical volume.

When a logical volume is mirrored, the following changes are not allowed:

  • From nonstrict to strict

  • From nonstrict to PVG-strict

  • From strict to PVG-strict

-t IO_timeout

Set the IO_timeout for the logical volume to the number of seconds indicated. This value will be used to determine how long to wait for IO requests to complete before concluding that an IO request cannot be completed. An IO_timeout value of zero (0) causes the system to use the default value of "forever". NOTE: The actual duration of the request may exceed the specified IO_timeout value when the underlying physical volume(s) have timeouts which either exceed this IO_timeout value or are not integer multiples of this value.

EXTERNAL INFLUENCES

Environment Variables

LANG determines the language in which messages are displayed.

If LANG is not specified or is null, it defaults to "C" (see lang(5)).

If any internationalization variable contains an invalid setting, all internationalization variables default to "C" (see environ(5)).

EXAMPLES

Change the permission of a logical volume to read-only:

lvchange -p r /dev/vg01/lvol3

Change the allocation policy of a logical volume to nonstrict:

lvchange -s n /dev/vg01/lvol7

Turn the mirror write cache off on a logical volume:

lvchange -M n /dev/vg01/lvol1

Change the IO timeout value of a logical volume to 1 minute (60 seconds):

lvchange -t 60 /dev/vg01/lvol1

WARNINGS

For root, swap or dump logical volumes, the allocation policy is always contiguous. This attribute cannot be changed with lvchange.

DEPENDENCIES

The -r option is not available on HP-IB devices.

© Hewlett-Packard Development Company, L.P.