HPlogo HP-UX Reference Volume 2 of 5 > f

fcmsutil(1M)

» 

Technical documentation

Complete book in PDF

 » Table of Contents

 » Index

NAME

fcmsutil — Fibre Channel Mass Storage Utility Command for the TACHYON A3740A, A3591A, A3404A, A3636A, and TACHYON TL A5158A Fibre Channel Host Bus Adapters.

SYNOPSIS

/opt/fcms/bin/fcmsutil device_file

/opt/fcms/bin/fcmsutil device_file echo remote-N-Port-ID [data-size] [count]

/opt/fcms/bin/fcmsutil device_file rls remote-N-Port-ID

/opt/fcms/bin/fcmsutil device_file test remote-N-Port-ID [data-size] [count]

/opt/fcms/bin/fcmsutil device_file read offset [pci]

/opt/fcms/bin/fcmsutil device_file write offset [pci]

/opt/fcms/bin/fcmsutil device_file [-f] lb [ plm | tachyon ]

/opt/fcms/bin/fcmsutil device_file get local|fabric

/opt/fcms/bin/fcmsutil device_file get remote N-Port-ID

/opt/fcms/bin/fcmsutil device_file get_lgn N-Port-ID

/opt/fcms/bin/fcmsutil device_file reset

/opt/fcms/bin/fcmsutil device_file [-f] bdr target-device_file

/opt/fcms/bin/fcmsutil device_file read_cr

/opt/fcms/bin/fcmsutil device_file lgninfo_all

/opt/fcms/bin/fcmsutil device_file stat [-s]

/opt/fcms/bin/fcmsutil device_file clear_stat

/opt/fcms/bin/fcmsutil device_file devstat { all | remote-N-Port-ID }

/opt/fcms/bin/fcmsutil device_file clear_devstat { all | remote-N-Port-ID }

/opt/fcms/bin/fcmsutil device_file replace_dsk remote-N-Port-ID

/opt/fcms/bin/fcmsutil device_file [-f] disable

/opt/fcms/bin/fcmsutil device_file enable

Note: For the TACHYON TL A5158A card, remote-N-port-ID can be substituted with -l loop_id, for all options that take remote-N-port-ID as an argument. The devstat all option displays the loop_id along with the statistics for all N_Ports, the initiator was able to communicate with.

DESCRIPTION

The fcmsutil command is a diagnostic tool to be used for the TACHYON A3740A, A3591A, A3404A, A3636A and TACHYON TL A5158A Fibre Channel Host Bus Adapters. This command provides the ability to perform Fibre Channel Test and Echo functionality, read the card's registers, etc. This command requires the use of a device file to indicate the interface over which the requested command needs to be performed. fcmsutil can be used only by users who have an effective user ID of 0. Some of the options require detailed knowledge of the device specific adapter.

Options

fcmsutil recognizes the following options as indicated in SYNOPSIS. All keywords are case-insensitive and are position dependent.

device_file

Can be used alone or with other options.

When used without any options it provides information such as the N_Port ID, Node World Wide Name and Port World Wide Name, Topology of the Fabric, the Speed of the Link, the Hard Physical Address of the Card, the Driver State, the number of Active Outbound Exchanges and number of Active Logins.

For the TACHYON TL A5158A card, it provides information such as the N_port_ID, Node World Wide Name and Port World Wide Name, Topology, Vendor ID, Device ID, the Driver State, number of Assisted IOs and number of Active Logins. As per the protocol, Node WWN will be one more than the Port WWN.

The following topologies are defined:

UNKNOWN. The host adaptor card is not attached to a loop/loopback hood or has connection problems and could not come up in a valid topology.

IN_LOOP. The card is attached to a loop/loopback hood.

IN_LOOP_FL. Not supported.

IN_PTTOPT_NPORT. The card has come up in a point to point topology. This topology can be an error if the the card was expected to come up in loop topology. Not legal in most cases.

IN_PTOPT_FABRIC. The card has come up in a point to point topology when connected through a Fibre Channel switch. This topology can be an error if the the card was expected to come up in loop topology. Not legal in most cases.

IN_PTTOPT This is a transition topology. Not legal in most cases.

The following are the driver states:

DEAD. The driver couldn't come up due to some problem. Check the connectivity with the loop/loopback hood.

LOOPBACK_STATE. The host bus adaptor is in the loop back test phase.

OFFLINE. The host bus adaptor card is not participating on the loop.

READY/ONLINE. The driver is up and functional.

RESETTING. The host bus adaptor card is being reset.

All other states are only transient and should not continue for long. If the transient state persists there might be a problem in the hardware connectivity or configuration.

echo

This option requires two parameters, the remote-N-Port-ID and data-size (size of packet to send). An optional third argument (count) can be specified for the number of echo packets to be sent. If the count option is not specified, one packet will be sent. The count option is supported only by the TACHYON TL A5158A card.

Fibre Channel Echo packet(s) of the specified size is sent to the remote node. The command completes successfully when an echo response is received from the remote node and matches the data sent, for all packets sent. The command times out if a response is not received in twice RA_TOV time.

Note: Packet size specified must be a multiple of 4.

rls

This option requires one parameter, the remote-N-Port-ID. A Fibre Channel Request Link Status (RLS) ELS is sent to the remote-N-Port-ID and the response data is displayed.

test

This option requires two parameters, the remote-N-Port-ID and data-size (size of packet to send). An optional third argument (count) can be specified for the number of echo packets to be sent. If the count option is not specified, one packet will be sent. The count option is supported only by the TACHYON TL A5158A card.

A Fibre Channel Test packet of the specified size is sent to the remote node. The command completes successfully and immediately on sending all the test packets.

Note: Packet size specified must be a multiple of 4.

read

This option requires one parameter, the offset of the register to read from. The offset can be specified in either hex or in decimal format. The offset specified is an offset from the base of the Memory Map. The user of this command is therefore expected to have internal knowledge of the chip. Reading from the Tachyon frame manager status register (0x01c8) is restricted.

An optional second argument (pci) can be specified for the TACHYON TL A5158A card, to read from the PCI config space. If no second argument is specified, it reads from the chip register space.

write

This option requires two parameters, the offset of the register to write to and the value to be written.

An optional third argument (pci) can be specified for the TACHYON TL A5158A card, to write into the PCI config space. If no third argument is specified, it writes into the chip register space.

lb

WARNING: This is a DESTRUCTIVE test and DATA LOSS during the execution of this test may occur. The -f option can be used to suppress the warning message displayed by the TACHYON TL A5158A card.

This option requires one parameter, tachyon or plm. The TACHYON TL A5158A card supports only the plm option. An optional third argument (count) can be specified for the number of loopback packets to be sent. If the count option is not specified, one packet will be sent. The count option is supported only by the TACHYON TL A5158A card.

This command performs an internal loopback test when the tachyon option is specified and performs an external loopback test when plm option is specified. The fibre channel chip is programmed in either internal loopback mode (tachyon) or external loopback mode (plm) based on the parameter specified. Here plm refers to physical link module or gigabit link module. The self test then involves sending a packet and receiving back the packet within the adapter and checking its integrity. Since this self test is at the adapter level, no packet goes on the fibre link.

get

The get option is used to obtain Fibre Channel login parameters of either the local port, the fabric port or of a remote port. The TACHYON TL A5158A card supports only the remote option.

get_lgn

The get_lgn option is used to obtain detailed information maintained in the login block associated with each N_Port that this N_Port has communicated with. The remote-N-Port-ID is a required parameter for this option. This option is not supported by the TACHYON TL A5158A card.

reset

resets the fibre channel card. This is a destructive test and communication to all nodes will be terminated till the reset process is completed. This option only results in a soft reset for the TACHYON TL A5158A card and does not result in termination of communication.

bdr

WARNING: This is a DESTRUCTIVE test. The -f option can be used to suppress the warning message displayed by the TACHYON TL A5158A card.

This option resets the target, clearing all commands, without doing any checks. This option is supported only by the TACHYON TL A5158A card.

read_cr

This option can be used to read all of the readable registers on the card and format the detailed information.

lgninfo_all

This option is used to obtain a comprehensive list of nodes to which a successful login has been established. This option is not supported by the TACHYON TL A5158A card.

stat

This option is used to obtain detailed statistics maintained by the driver. An optional argument (-s) can be specified for the TACHYON TL A5158A card, to obtain a shortened version of the statistics maintained by the driver.

clear_stat

This option is used to clear the statistics maintained by the driver. This option is supported only by the TACHYON TL A5158A card.

devstat

The devstat option is used to obtain detailed statistics associated with each N_Port that this N_Port has communicated with.

If the remote-N-Port-ID is specified, then the statistics associated with that N_Port are displayed. If the all option is specified, statistics associated with all N_ports that the initiator has been able to communicate with, are displayed.

This option is supported only by the TACHYON TL A5158A card.

clear_devstat

This option is used to clear the statistics associated with a target.

If the remote-N-Port-ID is specified, then the statistics associated with that N_port are cleared. If the all option is specified, statistics associated with all valid N_Port_IDs are cleared.

This option is supported only by the TACHYON TL A5158A card.

replace_dsk

This option is used to specify that no authentication should be performed the next time we communicate with the device. This option is to be used by system administrators for replacing a disk, with another (with the same N_Port_ID). Note that this is not required, if the new disk acquires a new N_Port_ID.

This option is supported only by the TACHYON TL A5158A card.

disable

WARNING: This is a DESTRUCTIVE test and communication to all nodes will be terminated. The -f option can be used to suppress the warning message displayed by the TACHYON TL A5158A card.

This option is used to disable a card, typically because of a hardware problem which cannot be resolved and is interfering with system performance.

enable

This option is used to enable a card, typically when a previous hardware problem has been resolved.

EXAMPLES

Print a short listing of the statistics maintained by the driver, with /dev/td1 as the device file.

fcmsutil /dev/td1 stat -s

Send 5 echo packets of 200 bytes each to a remote N_Port with loop_id 4, with /dev/td1 as the device file

fcmsutil /dev/td1 echo -l 4 200 5

AUTHOR

/opt/fcms/bin/fcmsutil was developed by HP.

© Hewlett-Packard Development Company, L.P.