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1. Product Identification

1.1. Product Name

This project is known internally as STM. This document describes the external
specifications for the LOGTOOL utility.

1.2. Document Change History

Revision 1.00 - 4/15/94 First Publication

Revision 1.1 - 4/19/94 Numerous changes made to reflect the evolving design of
STM logging. Added appendices with formats of each log
entry type and the logger configuration file.

Revision 1.2 - 8/16/94 Added a feature to enable users to invoke a specified
program to be invoked to process specific entries that are
received by the Logger process.

Revision 1.3 - 3/27/95 Updated filter fields to reflect changes in the product
fields available in the map. Basically, the product and
description fields have been merged so the description
filter field was eliminated.

Revision 1.4 - 11/7/95 Updated filter fields for program to be invoked for
specific entries.

Revision 1.5 - 11/10/95 Updated diagrams for new log types, header entries and
header entry values.

Revision 1.6 - 11/14/95 More updates to header structures.  Removed all mention
of STM Formatter.

Revision 1.7 - 11/16/95 More updates to the diaglogd configuration file.  Added
hversion to lpmc entry type.

Revision 1.8 - 04/30/97     Replaced figures with actual screen pictures.  Updated text
to match new pictures where appropriate.  Added
information regarding memory menu command
selections.

Revision 1.9 - 06/20/97 Changed Logtool’s Main Window figure
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Revision 1.10- 07/21/97 Made changes to incorporate selection of current raw log
file as default.  Made changes where appropriate for
logtool “shortcut” commands.  (Introduced in Logtool
Version 2.0.)

Revision 1.11– 10/29/97 Reformatted to make document suitable for HP
customers.

Revision 1.12– 11/26/97 Made changes to incorporate multiple file selection
capability.  (Introduced in Logtool Version 3.0.)

Revision 1.13- 02/12/98 Modified Filter dialog screens to incorporate the
capability to filter on a range of entries in the log file
(Introduced in Logtool Version 5.0.)

Revision 1.14- 04/15/98 Modified Select Raw and Select Formatted dialog screens
to show new file size/date/time information.  Modified
Filter dialog screens with changes to entry type filter
selections.  (Introduced in Logtool Version 5.10).

Revision 1.15- 08/05/98 Modified View and Summary screens with changes to
button selections. These changes are not directly tied to a
Logtool Version.

Revision 1.16- 08/26/98 Modified Filter dialog screens and View Log screens with
changes for entry id number.  (Introduced in Logtool
Version 6.0).

Revision 1.17- 10/07/98 Modified Appendix A to reflect addition of Entry Index to
log entry structures.  (Introduced in Logtool Version 6.0
for Event Notification).

1.3. Overview

STM utility programs are one of the eight architected types of support tools. They are
designed to provide various services that do not fall under the scope of the other
types of support tools. Unlike the other support tool types, utility programs such as
this one are not device specific and do not require selection of a device to run.
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2.  Functional Overview

2.1. Tool Strategy

Logtool is an interactive utility that runs on the STM platform, providing users with
access to the system log files.  Logtool has four main command categories: File,
View, Filters and Memory.  The File commands allow the user to select log files,
switch log files, or exit (i.e., quit) Logtool. The View commands display summary
data on selected log files or the contents of the logs. The Filters commands enable the
user to set up formatting and display filters that can be used to specify exactly what
type of entries the user is interested in. The Memory commands allow the user to
recreate and /or view the contents of the memory log file and to set the interval for
polling for memory errors.

2.1.1. Assumptions

It is not currently anticipated that Logtool will need to log information of its own
into its Tool Activity Log. However, if errors are encountered by Logtool or the
STM service routines that it calls, error information may be written to this log to
assist in debugging. The type of errors that may be encountered and the
corresponding log information is not known at this time.

This specification addresses the logging strategy that is used on HP-UX systems.
If STM is ported to other operating systems, the logging strategy is likely to be
somewhat different than what is described in this document.

2.1.2. External Dependencies

Logtool is a log formatting display utility. The actual formatting of a raw log file
into a displaceable format is done in part by Logtool and in part by decode
routines at the request of Logtool, as will be discussed later.

2.1.3. Implementation Specific Errors and Corresponding Actions

It is not possible for this specification to address all of the potential conditions
which could arise in the course of any operating system running this utility.
Therefore, it is expected that the implementor of this utility will be responsible
for anticipating and addressing any implementation specific errors and/or actions
not identified in this specification.
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2.2. Operational Overview

Utilities are invoked via the  Utilities sub-menu under the  Tools menu in the STM
User Interface. Selection of this command will cause a cascade menu to be displayed
with the names of all of the utility programs that are currently installed. The user
should select the "Logtool" entry to invoke this tool.

2.3. User Perspectives

2.3.1. Utility Options

The figure below shows the options that are available for utilities. These options
can be changed via the Tool Options sub-menu of the Options menu in the STM
User Interface. The only option that is available for utilities is that which
controls the type of information that is logged to the Tool Activity Log.

2.4. STM Logging Strategy

Log data is maintained on the system in raw form (e.g., Raw Log in the following
figure) which consists of a header for each entry that is generated by the logging
process followed by the raw data supplied by the driver or other logging entity. In
order to display the data in text understandable to most users, the contents of the raw
log must be formatted and placed into a formatted log. The formatted data for each
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entry consists of a header that is generated by Logtool and a series of language
localized message descriptors that are generated by log decoding programs associated
with each logging entity (e.g. i/o driver) or entry type (e.g. lpmc entry). The contents
of the formatted log can then be displayed to the user by retrieving message text from
catalogs associated with each message specifier and displaying it. If no decoding
routine is installed for a particular logging entity, Logtool will provide only the
header information for entries associated with it and a hex display of the raw data for
those entries.

The following figure shows an example of how a raw log file whose first entry is an
I/O error is formatted. Refer to Appendix A for the contents of other entry types.

Logtool provides commands to view either the raw log file data (in hex), or the
formatted output (in text).
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Since it is possible for there to be a large amount of data in a given log file or series
of log files, Logtool gives the user a set of formatting and display filters that enable
the user to select only those log entries that are of interest for formatting or viewing.
The formatting filter is used to selectively format only raw entries that the user is
interested in and the display filters are used to selectively display the formatted or
raw entries that the user is interested in.

For example, a user could specify that only log entries for disk drives should be
formatted which would result in a formatted log file containing only disk entries.
Later, when displaying the entries, the user might decide to display only entries for
Hard disks, or only disks on a certain path, etc.

The following diagram outlines the general flow of data between the STM logger,
log files and Logtool. The thick solid arrows in the diagram represent data flows and
the thin solid arrows show how the various filters are generated. The dashed boxes
represent processes or logical blocks of code. For example, the Logtool box and the
STM Logger box represent separate processes.
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In addition to the various filters implemented by Logtool, the STM Logger process
also has the capability to filter log data based on certain criteria. This enables the user
to "turn off" logging of entries that are of no interest. Entries that are filtered out via
the logger process are discarded and not placed in the raw log file, thus saving disk
space. This filter can be modified by editing the logger configuration file.

The Logger process also enables the user to invoke specific programs when particular
entries are logged. The program that is invoked will be passed the raw log entry on
which it will presumably do some special case processing.  An example of a practical
application of this feature could be to monitor log entries from a particular device
and generate messages to the system console if critical errors are detected. It should
be noted that the Logger process will log the entry as usual after passing it to the
specified program. The user can specify which programs to invoke for which log
entries in the logger configuration file.

Refer to Appendix B for details on the logger configuration file.

2.5. Log File Naming Conventions

Raw log files have names of the form logn.raw, where n is a number that starts at one
and is incremented each time a new log file is created via the Switch Log command.
The exception to this is the log file to which the logger is currently logging which is
called logn.raw.cur.  Formatted log files have names of the form logn.fmtn where the
first number matches that of the raw log file from which it was generated and the
second number starts at one and is incremented by one for each new formatted file
that is generated from the same raw log file.  In the case where multiple files were
selected to be formatted together, the filename will have a plus sign, “+”, in it.  For
example, log1.raw and log2.raw would be formatted in to the file log1+.fmt1.

On HP-UX systems, the default directory of the system log files is /var/stm/logs/os.
Formatted log files will be stored in the same directory by default.   The memory log
file, memlog, is also located in the /var/stm/logs/os directory.

2.6. Log Entry Types

The actual contents of the I/O error logs is system dependent.  The logs currently
contain the following types of entries:

• I/O Errors (logged by drivers)
• LPMC
• System Overtemp
• LVM Errors (logged by LVM system)
• Logger Events
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Although the examples in this document focus on I/O error entries, which are
expected to be the most prevalent, the principles of each example apply to the other
entry types as well.

2.7. Operational Overview

All of the Logtool commands can be invoked via: a GUI interface, a menu interface,
or a command line interface. In all cases, the user is presented with four categories of
commands.  The user selects the appropriate command depending upon the desired
operation.  The examples in this ERS use the X-Windows GUI interface. All of the
functionality presented is available in the menu and command line interfaces as well.
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3. User Interface

Logtool commands allow the user to easily search a computer system’s I/O and memory
error log files. The User Interface is designed with usability as a foremost concern which
means it strives to be as intuitive as possible while also providing as much capability as
possible.

3.1. Logtool Commands

In an effort to keep Logtool simple for the user, only four command categories
(called menus) exist.  The following table shows the four categories of Logtool
commands arranged as one menu per column.

File View Filters Memory

Select Raw... Raw Summary Format... Clear Log
Format Raw... Raw Log Display--> Set Timer...
Select Formatted... Formatted Summary Report Log-->
Switch Log Formatted Log
Save As...
Print...
Exit…

In the above table, note that some commands have an ellipse (...) after them. This
signifies that if one of these commands is selected, a dialog screen of some type will
be presented before anything is actually done. For example, if Select Raw is chosen,
the user will be asked for the raw file name before a file is actually selected. Also
note that some commands have an arrow next to them, indicating that there is more
than one command to choose from. These commands are available via a cascade
menu. The commands available in each cascade menu are shown in the following
tables:

Display

Raw...
Formatted...

Report Log

View Dealloc
View Detail
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3.2. Logtool Main Window

When Logtool is first invoked from the Utility menu of the STM User Interface, the
main command window is displayed. This window contains a set of command menus
through which the user selects operations for Logtool to perform. The contents of
these menus were discussed in the previous section. This screen also provides a
scrolling information area where Logtool can display informational messages to the
user. The following sample screen shows the main command window.
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3.3. Typical Logtool Usage

A typical Logtool session could consist of the following activities:

• View a summary of a raw log file on the system and determine if any entries
have been logged that are of interest.

• If the raw log summary indicates that there are some entries of interest:

• Set up a format filter which will filter out all entries except for those of
interest.

• Format the raw log file(s).

• Display the formatted log file.

Once a formatted log file has been generated, the user may wish to further narrow the
entries that are displayed. This can be done by setting the formatted display filter to
the appropriate values prior to displaying the log. For example, the user may have
used a format filter to format all entries from the SCSI disk driver. After viewing a
summary of the formatted entries, the user may decide that only entries for a
particular device or, perhaps, only entries after a certain date and time are of interest.
The user could then set the formatted display filter to specify a specific device path
and/or date and time and view the formatted log.

The commands used in these examples, as well as other Logtool commands, are all
discussed in detail in the following section.
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4. Detailed Command Descriptions

4.1. Commands within the File Menu

4.1.1. Select Raw

This command displays the names of the raw log files that are currently on the
system and allows the user to select one or more of them for viewing, filtering or
formatting. The initial file filter is set to the default location and naming
convention for raw log files and the default file selection defaults to the current
raw logfile, if there is one. Users can access the default file, specify a file from
the files list presented, or they can specify a file of their own choosing. In this
case, caution should be exercised since only log files that were generated on the
host system should be formatted on that system. Attempts to format log files
from other systems may result in formatting problems or incorrect formatted
output. Once a formatted log is generated, it may be moved to other systems and
displayed without any problems.

When a raw log file is selected, it is automatically read and summarized by
Logtool, which may cause a short delay if the file is large or several files have
been selected.  The summary data reflects totals of all log entries from all
selected files integrated together and treated as one file. This summary
information is then automatically displayed to the user.  The summary can be
displayed independently at any time via the Raw Summary command under the
View menu. This summary information is used by Logtool to determine
appropriate values for fields that can be set in the raw display filter as well as in
the format filter. If the log file to which the logger is currently logging,
logn.raw.cur, is selected, the output of subsequent commands such as the Raw
Log command under the View menu or the Format Raw command under the File
menu may reflect additional records and/or counts that weren’t displayed
initially.  This is because more errors may have been logged to the currently
active file since it was initially selected and read.

The following figure shows the screen that is displayed in the GUI when the
Select Raw command is selected.   Note the current raw log file in this example
is shown as log2.raw.cur. If desired, users can enter a new file filter in the Filter
box and click on the Filter button when done. The new filter will then be applied
and a list of files that match will be displayed.

Users can change directories by simply clicking on the directories listed in the
Directories box. Once the correct directory has been selected, a file is selected
by clicking on its name in the Files box and clicking the OK button at the bottom
of the screen.
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If the user wishes to exit this command without selecting a file, the Cancel
button which will take the user back to the main menu screen should be selected.

Clicking on the Help button will provide help on how to perform a file selection.
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4.1.2. Format Raw

This command is used to format any raw log files that were previously selected
via the Select Raw command under the File menu. If no files were selected, the
current raw log file, if there is one, is used as the default. Depending on how
much data is in the selected files, the Format Raw command may take several
minutes to complete.  If more than one file was selected, all the log entries from
all the files will be formatted on a per-file basis and concatenated in one
continuous flow into one formatted file.

The entries in the raw log will first be filtered according to any Format filter
settings.  If no filters have been selected, all entries will be formatted. Refer to
the Filters Menu Section for more information.  Entries which do not match the
filter will not be formatted. If the user wishes to format entries which were
previously filtered out, the filter should be changed and the log reformatted.

The header portion of each entry is architected and will be interpreted and
formatted into text by Logtool. The data portion of each entry is not architected
and will be interpreted and formatted into text by the appropriate log decoding
routine. If an appropriate log decoding program cannot be located for a particular
entry, the data portion of the entry will be formatted for display in hex by
Logtool.

The output file name is selected automatically based on the raw log file name.
The raw log file log1.raw becomes log1.fmtn where n is incremented every time
a format is done on log1.raw.  This file naming convention for formatted log
files allows the user to generate several different formatted versions of a raw log
file, all presumably generated using different filters, and easily tell from which
raw log file they were generated.  For example, log1.fmt1 and log1.fmt2 were
both formatted from the same raw log file --log1.raw.  In the case where
multiple files were selected to be formatted together, the filename will have a
plus sign, “+”, in it.  For example, log1.raw and log2.raw would be formatted
into the file log1+.fmt1.

When the  OK button is selected, the user then selects a directory into which to
place the formatted log file.  The default log directory is supplied.  The format
process is then invoked and once the format process is complete, the filename
where the output was placed will be displayed in Logtool’s main window.  Once
formatting is complete the formatted log summary is automatically displayed.
The formatted file automatically becomes the selected formatted file that will be
displayed or summarized by the Formatted Summary and Formatted Log
commands under the View menu.  See the following figures for samples of the
dialog screens presented during the Format Raw process.
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4.1.3. Select Formatted

This command displays the names of the formatted log files that are currently in
the default log directory on the system and allows the user to select one or more
of them for viewing or filtering. The initial filter will be set to the default
location for formatted log files. Users can specify a file from the files list
presented or they can optionally specify a file of their own choosing.

When a formatted log file is selected, it is automatically read and summarized by
Logtool, which may cause a short delay if the file is large or several files have
been selected.  The summary data reflects totals of all log entries from all
selected files, integrated together and treated as one file. This summary
information is then automatically displayed to the user.  The summary can be
displayed independently at any time via the Formatted Summary command
under the View menu. This summary information is used by Logtool to
determine appropriate values for fields that can be set in the Display--
>Formatted filter. Refer to the Filters menu for more information.

The following figure shows the screen that is displayed in the GUI when the
Select Formatted command is selected. In this example log1.fmt1 has been
selected. Users can enter a new file filter, if desired, in the Filter box and click
on the Filter button when done. The new filter will then be applied and a list of
files that match will be displayed.

Users can change directories by simply clicking on the directories listed in the
Directories box. Once the correct directory has been selected, the user selects a
file by clicking on its name in the Files box and clicking the OK button at the
bottom of the screen.

If the user wishes to exit this command without selecting a file, the Cancel
button should be selected which will take the user back to the main menu screen.

Clicking on the Help button will provide help on how to perform a file selection.
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4.1.4. Switch Log

This command causes the STM logger to open a new current log file. It may be
desirable to issue this command occasionally in order to keep individual log files
from becoming larger than what is desirable. The new log file that is created by
the logger process will be named according to the standard naming convention
with the number incremented by one. Thus, if the current log file is called
log5.raw.cur, the new one will be called log6.raw.cur and the old one will be
renamed to log5.raw to signify that it is no longer current.

This command is provided as a convenience to the user. The user can
accomplish a switch log manually by simply renaming the current log file. When
the logger process notices that there is no logn.raw.cur  file present, it will create
a new one. Thus, to accomplish the same thing as the above Switch Log
example, the user could have issued the system command "mv log5.raw.cur
log5.raw".

4.1.5. Save As

This command is used to save the contents of Logtool’s main window.  Only the
most recent 200 lines can be saved.  The user is presented with a dialog box in
which they can specify their desired filename.

4.1.6. Print

This command is used to print the contents of Logtool’s main window.  Only the
most recent 200 lines can be printed.

4.1.7. Exit

This command exits Logtool. The user is asked to confirm that they want to exit,
as is shown in the dialog box figure that follows.
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4.2. Commands within the View Menu

4.2.1. Raw Summary

This command displays a summary of the currently selected raw log file or files.
If a file was not selected via the Select Raw command under the File menu, then
the current raw log file, if there is one, is used as the default. The summary is a
report of the total number of each entry type that occurs in the file.  In the case of
I/O error entries there is a unique list of device paths, products, product
qualifiers and logger events and the count shown for the number of times each
occurs in the file is shown in parentheses. The summary data reflects totals of all
log entries from all selected files, integrated together and treated as one file. This
summary information is the same information that is used in the Format
command under the Filters menu and the Raw command under the Filters--
>Display menu to specify exactly what subset of entries should be formatted via
the Format Raw command under the File menu. Refer to those commands for
more details.

The following figure shows the screen that is displayed in the GUI when this
command is selected. Note that information is only given for entries that are
actually in the log file. Thus, there was one lvm error and two I/O errors in this
log file.  The I/O errors were generated on two different device paths, by two
different products with two different product qualifiers and two different
loggers.

In this screen, the user has the option to scroll through the summary information
using the scroll bar at the right, perform a case-sensitive search (Search and
FindNext), print the information to a printer (Print), save the information to a
file (SaveAs), close the window (Done) or ask for help (Help).
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4.2.2. Raw Log

This command displays the contents of all the raw log files selected with the
Select Raw command under the File menu   If  no files were selected, the current
raw log file, if there is one, is used as the default. Each entry consists of a header
and data. The header content is architected for all entries. The format of the data
portion is not architected and is under complete control of the logging entity
(e.g. I/O drivers). The header portion of the entry is interpreted and displayed in
text. The data portion of the entry is not interpreted and is displayed in hex.

The entries in the raw log file are first filtered according to the Raw filter under
the Filters --> Display menu.  Entries which do not match the filter will not be
displayed. If no filters were selected, all entries are displayed. The entries are
processed on a per-file basis, concatenated in a continuous flow and treated as
one file when displayed.  If the user wishes to display entries which were
previously filtered out, the filter should be changed and the log redisplayed.

The following figure shows the screen that is displayed in the GUI when the
Raw Log command is selected. In this example, only the first entry is shown. To
see the remaining entries, the user can use the scroll bar on the right of the
screen to scroll through the text, perform a case-sensitive search (Search and
FindNext), move from log entry to log entry (Prev and Next), print the
information to a printer (Print), save the information to a file (SaveAs), close the
window (Done) or ask for help (Help).  Note also in this example that the
Display Filter information shows the starting and ending dates which were in
force when the file was filtered.  These dates will match the date/time of the first
and last entry and will only change if the user selects date criteria on the filter
display screens.  Any other filters that were specified will also be displayed here.
In this example no filter criteria was specified.
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4.2.3. Formatted Summary

This command displays a summary of the currently selected formatted log file or
files. If a file was not selected via the Select Formatted command under the File
menu, then the current raw log file, if there is one, is used as the default. The
summary is a report of the total number of each entry type that occurs in the file.
In the case of I/O error entries there is a unique list of device paths, products,
product qualifiers, logger events, device types and device qualifiers and the
count shown for the number of times each occurs in the file is shown in
parentheses.  The summary data reflects totals of all log entries from all selected
files, integrated together and treated as one file. This summary information is the
same information that is used in the Formatted command under the Filters -->
Display menu to specify exactly what subset of entries should be displayed via
the Formatted Log command under the View menu. Refer to those commands
for more details.

The following figure shows the screen that is displayed in the GUI when the
Formatted Summary command is selected. Note that information is only given
for entries that are actually in the log file. The information in this example
represents what the output might look like if the raw log file shown in the
previous example was formatted without filtering out any entries. As mentioned
above, the numbers that appear in parentheses (nn) give the count of the number
of occurrences of the various items in the log file.

In this screen, the user has the option to scroll through the summary information
using the scroll bar at the right, perform a case-sensitive search (Search and
FindNext), print the information to a printer (Print), save the information to a
file (SaveAs), close the window (Done) or ask for help (Help).
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4.2.4. Formatted Log

This command displays the formatted log data that was generated by the Format
Raw command under the File menu. If a file was not selected via the Select
Formatted command under the File menu, then the current raw log file, if there
is one, is used as the default.  This default file is then automatically formatted
and that formatted log is displayed.  If more than one file was selected, the
entries from all the files are processed on a per-file basis and concatenated in
one continuous flow before being displayed.

The entries in the formatted log file will first be filtered according to the
Formatted settings under the Filters --> Display menu.  Entries which do not
match the filter will not be displayed. If the user wishes to display entries which
were previously filtered out, the filter should be changed and the log redisplayed.

The following figure shows the screen that is displayed in the GUI when the
Formatted Log command is selected.  In this example, only part of the first entry
is shown. To see the remaining entries, the user can use the scroll bar on the
right of the screen to scroll through the text, perform a case-sensitive search
(Search and Find Next), move from log entry to log entry (Prev and Next ), print
the information to a printer (Print), save the information to a file (SaveAs), close
the window (Done) or ask for help (Help).

The header information in this example indicates that when the raw log was
formatted, no format filters were in force other than the default starting and
ending entry dates. If the user wants to see specific entries, the Format filter
under the Filters menu should be changed and the raw log file should be
reformatted via the Format Raw command under the File menu.
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4.3. Commands within the Filters Menu

4.3.1. Format

This command is used to select the filter that will be used by Logtool to select
which entries in the selected raw log file(s) to format. In order to set the filter,
the user should first select a raw log file or files via the Select Raw command
under the File menu. If a file was not selected in this way then the current raw
log file, if there is one, is used as the default. Once a raw log file has been
selected, it is automatically summarized and only the items which actually occur
in the log file will be displayed as selections for filtering. These items will be
displayed in a dialog screen and the user can select as many items as desired.  If
more than one file was selected, all the log entries from all the files will be
integrated together and treated as one file.

Once one or more items has been selected, subsequent Format Raw commands
(under the File menu) will only format entries which match the filter criteria. An
entry is considered to be a match for a particular filter field if it matches any of
the selected items that were set in that field. If a field has no items selected, any
entry will match that field. In order for an entry to pass through the filter, it must
match the criteria for all of the filter fields.

For example, if the user selects a product of Flex Disk and a product qualifier of
HPC2254B, only entries for HPC2254B Flex Disks will be formatted/displayed.
If the user selects a device path of 52 and a product of Flex Disk, no entries will
be formatted/displayed if there is not a disk drive associated with path 52. If the
user selects paths 52 and 0/28.2.0 and does not select items in any of the other
filter fields, all entries for paths 52 and 0/28.2.0 will be formatted/displayed.

The starting and ending date/time fields will initially contain the date/time of the
first and last log entries. All log entries which are logged on or after the starting
date/time and on or before the ending date/time will be formatted. The user can
modify either or both of these fields as desired.

The following figure shows the screen that is displayed in the GUI when the
Format command is selected.  The figure is in two separate boxes for
documentation purposes only.  The GUI displays the screen in one box with
scroll bars available if needed.  The user can select various filter items and then
click on the OK button to return to the main menu. If the user wishes to exit
without changing the filter settings, the Cancel button should be used. The
Defaults button will undo any changes that have been selected.
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Below is what the top portion of the Set Format Filter dialog screen looks like:
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Below is what the bottom portion of the Set Format Filter dialog screen looks
like:
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4.3.2. Display --> Raw

This command is used to select the filter criteria that will be used by Logtool to
select which entries in the raw log file to display. In order to set the filter, the
user should first select a raw log file or files via the Select Raw command under
the File menu. If a file was not selected in this way then the current raw log file,
if there is one, is used as the default. Once a raw log file has been selected, it is
automatically summarized and only the items which actually occur in the log
will be displayed as selections for filtering. These items will be displayed in a
dialog screen and the user can select as many items as desired.  If more than one
file was selected, all the entries from all the files will be integrated together and
treated as one file.

Once one or more items has been selected, subsequent Raw Log commands
under the View menu will only display entries which match the filter criteria. An
entry is considered to be a match for a particular filter field if it matches any of
the selected items that were set in that field. If more than one item in a field is
selected, any entry must only match one of the items. If a field has no items
selected, any entry will match that field. In order for an entry to pass through the
filter, it must match the criteria for all of the filter fields.

The starting and ending date/time fields will initially contain the date/time of the
first and last log entries. All log entries which are logged on or after the starting
date/time and on or before the ending date/time will be displayed. The user can
modify either or both of these fields as desired.

In addition to providing filtering on each of the header fields, the user may want
to enter a specific hex pattern to search for which can be used to further narrow
the entries to the exact ones that are of interest. If a search pattern is specified, it
will be applied in addition to any other fields that have been specified, but only
to the data portion of each entry. Thus, for a raw display operation, one could
search for the occurrence of a specific hex pattern using this facility. The user is
cautioned that specifying a search pattern may result in a noticeable delay
because each entry must be converted to its hex display and the search pattern
applied. When a search pattern is not used, entries whose header contents do not
pass the filter are not converted to their hex display in order to save time.

The following figure shows the screen that is displayed in the GUI when this
command is selected.  The figures is in two separate boxes for documentation
purposes only.  The GUI displays the screen in one box with scroll bars available
if needed.  The user can select various filter items and then click on the OK
button to return to the main menu. If the user wishes to exit without changing the
filter settings, the Cancel button should be used.  The Defaults button will undo
any changes that have been selected.
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Below is what the top portion of the Set Raw Display Filter dialog screen looks
like:
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Below is what the bottom portion of the Select Raw Filters dialog screen looks
like:
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4.3.3. Display --> Formatted

This command is used to select the filter criteria that will be used by Logtool to
select which entries in the formatted log file to display. In order to set the filter,
there must be a currently active selected formatted file. This means that the user
should have first selected a formatted log file or files via the Select Formatted
command under the File menu; or have performed the Select Raw and Format
Raw commands under the File menu. If a file was not selected in one of these
ways, then the current raw log file, if there is one, is used as the default. This file
is then automatically formatted and that formatted log is then selected. Once a
formatted log file has been selected, it is automatically summarized and only the
items which actually occur in the log will be displayed as candidates for
filtering. These items will be displayed in a dialog screen and the user can select
as many items as desired.   If more than one file was selected, all the entries
from all the files will be integrated together and treated as one file.

Once one or more items has been selected, subsequent Formatted Log
commands under the View menu will only display entries which match the filter
criteria. An entry is considered to be a match for a particular filter field if it
matches any of the selected items that were set in that field. If more than one
item in a field is selected, any entry must only match one of the items. If a field
has no items selected, any entry will match that field. In order for an entry to
pass through the filter, it must match the criteria for all of the filter fields.

The starting and ending date/time fields will initially contain the date/time of the
first and last log entries. All log entries which are logged on or after the starting
date/time and on or before the ending date/time will be displayed. The user can
modify either or both of these fields as desired.

The following figure shows the screen that is displayed in the GUI when this
command is selected.  The figure is in two separate boxes for documentation
purposes only.  The GUI displays the screen in one box with scroll bars available
if needed.  The user can select various filter items and then click on the OK
button to return to the main menu. If the user wishes to exit without changing the
filter settings, the Cancel button should be used. The Defaults button will undo
any changes that have been selected.
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Below is what the top portion of the Set Formatted Display Filter dialog screen
looks like:
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Below is what the bottom portion of the Set Formatted Display Filter dialog
screen looks like:
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4.4.  Commands within the Memory Menu

4.4.1. Clear Log

This command allows the user to clear the memory log file. The user is
cautioned that performing this operation will result in the loss of any data that
was in the memory log file.  It is recommended that the user run the Memory
Log-->Detail command to verify that any data in the file is no longer needed.

4.4.2. Set Timer

This command allows the user to change the interval at which the memory
logging daemon polls the memory for errors. The figure below shows the screen
that is presented to the user.

4.4.3. Report Log-->View Dealloc

This command allows the user to view the deallocated page information from
the memory error log file.  The memory log file will be formatted and then
displayed to the user.  Depending on how many entries are in the file, this may
take a few minutes.  A dialog box is displayed to the user telling them how many
entries are in the file.  At this point they may either cancel the operation or
continue with the format and display of the file. See the example dialog box and
memory log report figures that follow.
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4.4.4. Report Log-->View Detail

This command allows the user to view the entire contents of the memory error
log file. The memory log file will be formatted and then displayed to the user.
Depending on how many entries are in the file, this may take a few minutes.  A
dialog box is displayed to the user telling them how many entries are in the file.
At this point they may either cancel the operation or continue with the format
and display of the file.  The figures below show the dialog box and a sample
memory error log file showing one entry.
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Appendix A - Log Entry Formats

There are several architected log entry formats that Logtool handles. For each entry, there
is a header portion that is architected. Additionally, each entry has a data portion which is
not architected. Logtool processes, formats, and displays the header fields and decoding
programs are used to handle the data portion. This strategy strikes a balance between
flexibility and usability in that Logtool can use the header information for summarizing
and filtering log entries but does not need to know the details of the data portion. Thus, to
change or enhance the data that is logged, all that is required is changing the appropriate
decoding program. The only instance in which Logtool itself would need to change is if a
new type of log entry is introduced or a change in the header information of one or more
entries is required.

The structure of each type of log entry is shown in the figure below. Following the
diagram, a brief description is provided.

I/O Error
Entry

(Entry Type = 1)

LPMC
Entry

(Entry Type = 2)

System
Overtemp

Entry
(Entry Type = 3)

LVM
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Header: Header: Header: Header: Header:
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    Logger ID . . . .
    Data Length . . . .
Data: .

.

.

.
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I/O Error Entry

I/O error entries are logged by I/O system drivers and typically contain information
concerning exception conditions that the driver encountered. The header for this
entry contains the following fields:

Entry Length The total length of the entry including the header.

Entry Type The type of entry. The value for I/O error entries is 1.

Entry Index The entry index is used in combination with the entry time stamp
to build the entry ID for this error event.

Entry Version The entry version indicates the version of the header for the type of
log entry this is.

Time Stamp The date/time that the logger process logged this entry.

Device Path The device path of the hardware module that is being controlled by
the driver which is logging. If NULL, the driver is not associated
with any physical hardware module.

Product ID The product identifier associated with the hardware module. This
identifier will be extracted from the system configuration map
entry corresponding to the Device Path above. If Device Path is
NULL, this field will be NULL also.

Logger ID The unique identifier of the driver that is logging this entry. The
decoder cross-reference file will be searched for a logger id that
matches this one. If an entry is found, the associated decoder or
monitor module will be invoked to decode the data portion of this
entry when the log is formatted. If no decoder cross-reference entry
is found, the entry will be formatted and displayed in hex.

Data Length The total length of the data portion of this entry.

LPMC Entry

This entry is logged by the system when a low priority machine check condition
occurs. The header for this entry contains the following fields:

Entry Length The total length of the entry including the header.

Entry Type The type of entry. The value for LPMC entries is 2.
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Entry Index The entry index is used in combination with the entry time stamp
to build the entry ID for this error event.

Entry Version The entry version indicates the version of the header for the type of
log entry this is.

Time Stamp The date/time that the logger process logged this entry.

Hversion Hversion of the main processor.

Data Length The total length of the data portion of this entry.

System Overtemp Entry

This entry is logged by the system when an overtemp condition occurs. The header
for this entry contains the following fields:

Entry Length The total length of the entry including the header.

Entry Type The type of entry. The value for system overtemp entries is 3.

Entry Index The entry index is used in combination with the entry time stamp
to build the entry id for this error event.

Entry Version The entry version indicates the version of the header for the type of
log entry this is.

Time Stamp The date/time that the logger process logged this entry.

Data Length The total length of the data portion of this entry.

LVM Entry

This entry is logged by the Logical Volume Manager and typically contain
information concerning exception conditions that the manager encountered. The
header for this entry contains the following fields:

Entry Length The total length of the entry including the header.

Entry Type The type of entry. The value for LVM entries is 4.

Entry Index The entry index is used in combination with the entry time stamp
to build the entry ID for this error event.
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Entry Version The entry version indicates the version of the header for the type of
log entry this is.

Time Stamp The date/time that the logger process logged this entry.

Data Length The total length of the data portion of this entry.

Logger Entry

This entry is logged by the logger process. The type of events that are logged via this
entry are things such as suspension of logging due to user request or because the
error rate of disk space thresholds were exceeded, and resumption of logging. Other
types of events may be added in the future as warranted. The header for this entry
contains the following fields:

Entry Length The total length of the entry including the header.

Entry Type The type of entry. The value for logger entries is 5.

Entry Index The entry index is used in combination with the entry time stamp
to build the entry ID for this error event.

Entry Version The entry version indicates the version of the header for the type of
log entry this is.

Time Stamp The date/time that the logger process logged this entry.

Data Length The total length of the data portion of this entry.
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Appendix B - Logger Configuration File

The STM Logger process utilizes a configuration file to allow the user to tailor its
operation. This file, called diaglogd.cfg, is automatically checked by the logger process
before each log entry is processed. If the file has changed, logger will read it and
reconfigure itself according to the settings in the file. If this file does not exist in the
appropriate directory (/var/stm/config/sys), the logger process will simply use its default
configuration values.

The logger configuration file may contain any or all of the following directives:
output-level level Sets the logging level for the diaglogd daemon.

Errors only level = 1
Errors and warnings level = 2
Errors, warnings and informationals level = 3

suspend Suspends all logging. Logging will remain
suspended until this directive is removed from the
configuration file.

suspend-type entry_type Suspends logging of entries of a particular type.
Logging for this type will remain suspended until
this directive is removed from the configuration file.

suspend-dev device_path Suspends logging of I/O error entries for a particular
device. Logging for this device will remain
suspended until this directive is removed from the
configuration file.

suspend-qual product_qual Suspends logging of I/O error entries for a particular
product qualifier. Logging for this product qualifier
will remain suspended until this directive is
removed from the configuration file.

suspend-logger logger_id Suspends logging of I/O error entries for a particular
logger_id. Logging for this logger_id will remain
suspended until this directive is removed from the
configuration file.

exec-type entry_type prog_name exec | no-exec [fifo_name]
If exec, executes a specified program when a
particular entry_type is logged. If fifo_name is
given,  passes it the raw log entry entry via the
specified FIFO file.  If no-exec, just passes the raw
log entry via the specified FIFO file.  In either case,
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the FIFO file will be created. Both fifo_name and
prog_name must be fully qualified.  The entry will
still be logged as usual by the STM logger.

exec-path device_path prog_name exec | no-exec [fifo_name]
If exec, executes a specified program when an I/O
error entry for a particular device is logged. If
fifo_name is given,  passes it the raw log entry entry
via the specified FIFO file.  If no-exec, just passes
the raw log entry via the specified FIFO file. In
either case, the FIFO file will be created. Both
fifo_name and prog_name must be fully qualified.
The entry will still be logged as usual by the STM
logger.

exec-qual product_qual  prog_name exec | no-exec [fifo_name]
If exec, executes a specified program when an I/O
error entry for a particular product qualifier is
logged.  If fifo_name is given,  passes it the raw log
entry entry via the specified FIFO file.  If no-exec,
just passes the raw log entry via the specified FIFO
file. In either case, the FIFO file will be created.
Both fifo_name and prog_name must be fully
qualified.  The entry will still be logged as usual by
the STM logger.

exec-logger logger_id prog_name exec | no-exec [fifo_name]
If exec, executes a specified program when an I/O
error entry for a particular logger_id is logged. If
fifo_name is given,  passes it the raw log entry entry
via the specified FIFO file.  If no-exec, just passes
the raw log entry via the specified FIFO file. In
either case, the FIFO file will be created. Both
fifo_name and prog_name must be fully qualified.
The entry will still be logged as usual by the STM
logger.

log-for-exec Enables logging of errors which occur during
attempts perform the above exec-xxx directives.
Errors are logged to the system activity log.  This
directive is expected to be used only to track
problems with newly added exec-xxx directives or
exec-xxx directives which do not appear to be
functioning properly.
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disk-threshold nn The % of disk space usage which, if exceeded, will
result in logging being suspended until the usage
drops back below this number. The default (i.e. if
this directive does not appear in the configuration
file) will be 95%.

rate-threshold nn The rate of logging, in number of entries per
minute, which if exceeded, will result in logging
being suspended until the rate drops back below this
number.  The default will be 50 entries per minute.

switch-threshold nn The size, in Kbytes, that the log file should be
allowed to grow to before switching to a new log.
The default will be unlimited.

Examples:

output-level 3 sets logging level to errors, warnings and
informationals

suspend-type 2 suspends logging of LPMC entries.
suspend-dev 1/0/0 suspends logging of entries for the device at 1/0/0.
suspend-prod HPC2473S suspends logging for product HPC2473S.
suspend-logger disc30 suspends logging for the disc30 driver.
exec-type 2 /usr/sbin/lpmc_prog exec /var/lpmc_fifo

invokes the program named lpmc_prog and passes it
the raw log entry for LPMC entries thru the FIFO
file /var/lpmc_fifo.

exec-dev 2/0/1.0.0 /usr/sbin/disk_prog exec /var/disk_fifo
invokes the program named disk_prog and passes it
the raw log entry for entries for device 2/0/1.0.0 thru
the FIFO file /var/disk_fifo.

exec-prod HPC35450A /usr/sbin/tape_prog exec /var/tape_fifo
invokes the program named tape_prog and passes it
the raw log entry for entries for product
HPC35450A thru the FIFO file /var/tape_fifo.

exec_logger tape2 /usr/sbin/tape_prog exec /var/tape_fifo
invokes the program named tape_prog and passes it
the raw log entry for entries for the tape2 driver thru
the FIFO file /var/tape_fifo.

exec-type 2 /usr/sbin/lpmc_prog no-exec /var/lpmc_fifo
passes the raw log entry for LPMC entries thru the
FIFO file /var/lpmc_fifo.

exec-dev 2/0/1.0.0 /usr/sbin/disk_prog no-exec /var/disk_fifo
passes the raw log entry for entries for device
2/0/1.0.0 thru the FIFO file /var/disk_fifo.
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exec-prod HPC35450A /usr/sbin/tape_prog no-exec /var/tape_fifo
passes the raw log entry for entries for product
HPC35450A thru the FIFO file /var/tape_fifo.

exec_logger tape2 /usr/sbin/tape_prog no-exec /var/tape_fifo
passes the raw log entry for entries for the tape2
driver thru the FIFO file /var/tape_fifo.

disk-threshold 80 suspends logging if disk space usage exceeds 80%.
rate-threshold 20 suspends logging if the rate exceeds 20

entries/minute.
switch-threshold 1000 switches log files when the current one reaches 1

Mbyte.

Whenever a directive is added to the configuration file that results in logging being
suspended, the logger process will log an entry itself which indicates when and for what
entries logging has been suspended. Similarly, when a directive is removed from the file
and logging is consequently resumed, an entry will be logged indicating when and for
what entries logging has been resumed along with the number of entries that were lost
during the suspension. Suspend/resume entries will also be logged by the logger when
thresholds are reached causing logging to suspend and again when logging is resumed.


